Opened 4 years ago

Closed 4 years ago

#56600 closed defect (fixed)

net-snmp: typedef redefinition with different types

Reported by: Schamschula (Marius Schamschula) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: net-snmp

Description

While building net-snmp @5.7.3 on High Sierra, I get the following error:

info:build libtool: compile:  /usr/bin/clang -I../include -I. -I../agent -I../agent/mibgroup -I../snmplib -I/opt/local/include -I/opt/local/include -DNETSNMP_ENABLE_IPV6 -fno-strict-aliasing -pipe -Os -arch x86_64 -Udarwin17 -Ddarwin17=darwin17 -fno-common -DPERL_DARWIN -mmacosx-version-min=10.13 -pipe -Os -fno-strict-aliasing -fstack-protector-strong -I/opt/local/include -DPERL_USE_SAFE_PUTENV -I/opt/local/lib/perl5/5.26/darwin-thread-multi-2level/CORE -c snmp_perl.c  -fno-common -DPIC -o .libs/snmp_perl.o
:info:build In file included from snmp_perl.c:9:
:info:build In file included from ../include/net-snmp/net-snmp-includes.h:71:
:info:build In file included from ../include/net-snmp/utilities.h:42:
:info:build ../include/net-snmp/library/int64.h:8:30: error: typedef redefinition with different types ('struct counter64' vs 'unsigned long')
:info:build     typedef struct counter64 U64;
:info:build                              ^
:info:build /opt/local/lib/perl5/5.26/darwin-thread-multi-2level/CORE/handy.h:179:17: note: previous definition is here
:info:build typedef U64TYPE U64;
:info:build                 ^
:info:build 1 error generated.

Attachments (1)

net-snmp-main.log.gz (14.6 KB) - added by Schamschula (Marius Schamschula) 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Schamschula (Marius Schamschula)

Attachment: net-snmp-main.log.gz added

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

I can't reproduce this, and I can't account for some of the differences between your log and mine. Do you have local modifications? For example, your log says:

:info:patch patching file configure
:info:patch Hunk #1 succeeded at 23928 (offset 518 lines).

On my system, the patch applies without fuzz.

On my system, the patch patch-agent-mibgroup-mibII-icmp.h.diff is used; on yours it's not.

On my system, all of the patches for all Darwin versions (patch-include-net-snmp-system-darwin11.h.diff patch-include-net-snmp-system-darwin12.h.diff patch-include-net-snmp-system-darwin13.h.diff patch-include-net-snmp-system-darwin14.h.diff patch-include-net-snmp-system-darwin15.h.diff patch-include-net-snmp-system-darwin16.h.diff patch-include-net-snmp-system-darwin17.h.diff patch-include-net-snmp-system-darwin18.h.diff) are used; on yours, only patch-include-net-snmp-system-darwin14.h.diff is used, which is not how the Portfile is written and also unexpected because you're on Darwin 17 not 14.

On my system, the configure flags --disable-agent --mandir=/opt/local/share/man --infodir=/opt/local/share/info are not used, but on yours they are; they don't appear in the Portfile.

On my system, the configure env var PERLPROG='/opt/local/bin/perl5.26' is set, but on yours it's PERLPROG='/opt/local/bin/perl'.

On my system, I see:

:info:configure checking for system include file... net-snmp/system/darwin17.h

On yours, you have:

:info:configure checking for system include file... net-snmp/system/darwin.h

comment:2 Changed 4 years ago by Schamschula (Marius Schamschula)

Resolution: fixed
Status: assignedclosed

Good catch. I had a local Portfile from 2014! that I had forgotten to delete.

Note: See TracTickets for help on using tickets.