Opened 3 years ago

Closed 3 years ago

#56744 closed defect (duplicate)

Failed to build osxfuse: command execution failed

Reported by: valorisa Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.5.2
Keywords: Cc:
Port: osxfuse

Description (last modified by mf2k (Frank Schima))

> sudo port -vvv selfupdate && sudo port -vvv upgrade outdated
PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
    cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-19b3fb7/framework
    /bin/sh -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-19b3fb7/framework/build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle, 9): Library not loaded: @rpath/libclang.dylib (LoadError)
  Referenced from: /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle
  Reason: image not found - /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.rb:6:in `<top (required)>'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /usr/bin/gen_bridge_metadata:65:in `<main>'
Command /bin/sh failed with exit code 1

** BUILD FAILED **


The following build commands failed:
	PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
(1 failure)
T:framework          | Failed to build target
Terminated: 15
Received signal: SIGTERM
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-19b3fb7" && ./build.sh -t packagemanager -a build -v 5 --build-directory="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work" -- -a x86_64 --framework-prefix="/opt/local" --fsbundle-prefix="/opt/local" --library-prefix="/opt/local" 
Killed by signal: 15
Error: Failed to build osxfuse: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Attachments (1)

main.log (3.1 MB) - added by valorisa 3 years ago.

Change History (7)

Changed 3 years ago by valorisa

Attachment: main.log added

comment:1 Changed 3 years ago by valorisa

Port: osxfuse added

comment:2 Changed 3 years ago by valorisa

> sudo port -vvv install ntfs-3g

PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh

cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-19b3fb7/framework /bin/sh -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-19b3fb7/framework/build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh

/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle, 9): Library not loaded: @rpath/libclang.dylib (LoadError)

Referenced from: /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle Reason: image not found - /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require' from /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.rb:6:in `<top (required)>' from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require' from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require' from /usr/bin/gen_bridge_metadata:65:in `<main>'

Command /bin/sh failed with exit code 1

BUILD FAILED

The following build commands failed:

PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh

(1 failure) T:framework | Failed to build target Terminated: 15 Received signal: SIGTERM Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-19b3fb7" && ./build.sh -t packagemanager -a build -v 5 --build-directory="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work" -- -a x86_64 --framework-prefix="/opt/local" --fsbundle-prefix="/opt/local" --library-prefix="/opt/local" Killed by signal: 15 Error: Failed to build osxfuse: command execution failed Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details. Error: Unable to execute port: upgrade osxfuse failed

comment:3 Changed 3 years ago by mf2k (Frank Schima)

Owner: set to drkp
Status: newassigned

In the future, please use WikiFormatting and add the port maintainer(s) to Cc (port info --maintainers osxfuse), if any.

Last edited 3 years ago by mf2k (Frank Schima) (previous) (diff)

comment:4 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:5 Changed 3 years ago by mf2k (Frank Schima)

Oh, I see you tried to use WIkiFormatting.

comment:6 Changed 3 years ago by kencu (Ken)

Resolution: duplicate
Status: assignedclosed

duplicate of 54939 and there is a workaround in that ticket

Note: See TracTickets for help on using tickets.