Opened 3 years ago

Closed 3 years ago

#56746 closed defect (fixed)

py27-pyqt4 not able to 'findqaxobject.h' in cfgtest_QAxContainer.cpp:1:10

Reported by: MountainLogic (Scott Elliott) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.5.2
Keywords: Cc: MountainLogic (Scott Elliott)
Port: py-pyqt4

Description

I am attempting to build GnuRadio that requires py27-pyqt4 in OSX 10.13.5. When building py27-pyqt4 I receive the following error:

QAxContainer -framework QtGui -F/opt/local/Library/Frameworks -framework QtCore -framework QtCore
:info:configure cfgtest_QAxContainer.cpp:1:10: fatal error: 'qaxobject.h' file not found
:info:configure #include <qaxError: Unable to create the C++ code.
:info:configure object.h>
:info:configure          ^~~~~~~~~~~~~
:info:configure 1 error generated.

With version info

:debug:sysinfo macOS 10.13 (darwin/17.6.0) arch i386
:debug:sysinfo MacPorts 2.5.2
:debug:sysinfo Xcode 9.4.1
:debug:sysinfo SDK 10.13
:debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 10.13

This seems odd as cfgtest_QAxContainer.cpp appears to refer to a Windows active X technology. See https://stackoverflow.com/questions/22672388/multiple-undefined-references-when-trying-to-build-pyqt4-from-the-sources. I assume that there might be a make define missing to build the Mac version.

I've attempted to clean py27-pyqt4, gnuradio etc with no luck (not installed). I had the working with a previous in Sierra with a previous version of gnu radio. QT4 is old and crufty, but the current gnu radio still requires it until its next major release.

Attachments (2)

main.log (35.5 KB) - added by MountainLogic (Scott Elliott) 3 years ago.
py27-pyqt4-main.log
sip_4.19.8_revert.diff (2.3 KB) - added by michaelld (Michael Dickens) 3 years ago.

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by MountainLogic (Scott Elliott)

Attachment: main.log added

py27-pyqt4-main.log

comment:1 Changed 3 years ago by MountainLogic (Scott Elliott)

Cc: MountainLogic added

comment:2 Changed 3 years ago by kencu (Ken)

The file is there:

$ locate qaxobject.h
/opt/local/libexec/qt4/include/Qt/qaxobject.h
/opt/local/libexec/qt4/share/doc/html/qaxobject.html

but your build is not finding it, for some reason...

comment:3 Changed 3 years ago by michaelld (Michael Dickens)

The issue is with SIP 4.19.10. I've got a query in to the lead developer.

comment:4 Changed 3 years ago by michaelld (Michael Dickens)

You'll see the same issue if you try to configure py*-qsci*-*, py*-PyQt4, and I'd guess py*-PyQt5 and some others.

Last edited 3 years ago by michaelld (Michael Dickens) (previous) (diff)

comment:5 Changed 3 years ago by mf2k (Frank Schima)

Cc: michaelld@… removed
Keywords: py27-pyqt4 gnuradio removed
Owner: set to michaelld
Port: py-pyqt4 added; py27-pyqt4 removed
Status: newassigned

Changed 3 years ago by michaelld (Michael Dickens)

Attachment: sip_4.19.8_revert.diff added

comment:6 Changed 3 years ago by michaelld (Michael Dickens)

Can folks here try the attached patch that reverts py*-sip to 4.19.8? Reverting in this manner seems to do the trick for me; wanted to verify with others before committing.

comment:7 Changed 3 years ago by michaelld (Michael Dickens)

Meh ... this change works for me as I hoped it would. I'm going to commit it as is & see how the dice roll LOL.

comment:8 Changed 3 years ago by michaelld (Michael Dickens)

In d994dc3010dc47777db3765f7b68e6a5425b639d/macports-ports (master):

py*-sip: revert to 4.19.8

... due to issues building py*-Qsci-qt* and PyQt*.

should address: #56746

comment:9 Changed 3 years ago by michaelld (Michael Dickens)

Can someone please report back whether this change worked or not?

comment:10 Changed 3 years ago by kencu (Ken)

works to build py27-pyqt4.

comment:11 Changed 3 years ago by mf2k (Frank Schima)

WFM with py36.

$ port installed py36-pyqt4 py36-sip
The following ports are currently installed:
  py36-pyqt4 @4.12.1_1 (active)
  py36-sip @4.19.8_0 (active)

comment:12 Changed 3 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

Great thx. Closing.

Note: See TracTickets for help on using tickets.