Opened 2 years ago

Closed 22 months ago

#56791 closed defect (worksforme)

p5.xx-event-rpc: errors during `port test`

Reported by: chrstphrchvz (Christopher Chavez) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc:
Port: p5-event-rpc

Description

While updating the p5-event-rpc port (cf. https://github.com/macports/macports-ports/pull/2151), I found that running port test p5.xx-event-rpc would error and hang on one of the tests, not allowing any remaining tests to be completed (for both the existing and updated versions):

--->  Testing p5.26-event-rpc
Executing:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_github.com_macports_macports-ports_perl_p5-event-rpc/p5.26-event-rpc/work/Event-RPC-1.08" && /usr/bin/make test
PERL_DL_NONLAZY=1 "/opt/local/bin/perl5.26" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01.use.t ............................... ok
t/02.cnct.t .............................. ok
t/03.cnct-auth.t ......................... ok
t/04.cnct-auth-ssl-verifypeer-noca.t ..... ok
Can't open SSL connection to localhost:27816: SSL connect attempt failed error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed at t/04.cnct-auth-ssl-verifypeer-wrongca.t line 57.
# Looks like your test exited with 255 just after 2.

However, this seems to be a MacPorts-related problem, since none of the distributions' tests fail when run manually as a normal user:

Downloads/Event-RPC-1.10$ make test
PERL_DL_NONLAZY=1 "/opt/local/bin/perl5.26" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01.use.t ............................... ok
t/02.cnct.t .............................. ok
t/03.cnct-auth.t ......................... ok
t/04.cnct-auth-ssl-verifypeer-noca.t ..... ok
t/04.cnct-auth-ssl-verifypeer-wrongca.t .. ok
t/04.cnct-auth-ssl-verifypeer.t .......... ok
t/04.cnct-auth-ssl.t ..................... ok
t/05.func.t .............................. ok
t/06.object2.t ........................... ok
t/07.maxpacket.t ......................... ok
t/08.msg_formats.t ....................... ok
All tests successful.
Files=11, Tests=155,  8 wallclock secs ( 0.08 usr  0.04 sys +  2.14 cusr  0.70 csys =  2.96 CPU)
Result: PASS

My only thoughts are that it might be due to the network functionality required by the test. I asked a few days ago on IRC if there were any ideas what might be going on, jmr_mp replied:

could be a number of things, different environment variables, running as a different user, sandboxing

Change History (3)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

I do not see this problem with p5.26-event-rpc 1.100.0 and MacPorts 2.5.3 on macOS Sierra 10.12.6. The tests completed without errors for me.

comment:2 Changed 22 months ago by chrstphrchvz (Christopher Chavez)

I could not reproduce this issue with Perl 5.28.1 on macOS Mojave 10.14.3. I guess this can be closed as worksforme.

comment:3 Changed 22 months ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.