Opened 3 years ago

Closed 3 years ago

#56804 closed defect (fixed)

arpack now requires a compiler that supports c++11

Reported by: kencu (Ken) Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: arpack

Description

arpack now wants c++11 during configure:

checking whether /usr/bin/clang++ supports C++11 features by default... no
checking whether /usr/bin/clang++ supports C++11 features with -std=gnu++11... yes

It somehow seems to build on 10.7 using the system clang and linking against libstdc++ log, but it fails on 10.6.8 log.

checking whether /usr/bin/g++-4.2 supports C++11 features by default... no
checking whether /usr/bin/g++-4.2 supports C++11 features with -std=gnu++11... no
checking whether /usr/bin/g++-4.2 supports C++11 features with -std=gnu++0x... no
configure: error: *** A compiler with support for C++11 language features is required.

Probably the best thing would be to add PortGroup cxx11 1.1 and revbump it to update the link libraries for consistency.

Change History (1)

comment:1 Changed 3 years ago by mamoll (Mark Moll)

Resolution: fixed
Status: assignedclosed

In 483d40b054fa7c93f7ff5019f06ba32440daeb1c/macports-ports (master):

math/arpack: a C++11 compiler is now required, so use cxx11 1.1 portgroup. closes #56804

Note: See TracTickets for help on using tickets.