Opened 2 years ago

Closed 21 months ago

#56867 closed defect (fixed)

inkscape @0.92.3_3 seems to be still 0.92.2

Reported by: fdesar Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc:
Port: inkscape

Description (last modified by ryandesign (Ryan Schmidt))

On OS X El Capitan (10.11.6), after installing inkscape 0.92.3 port, it seems the installed version is in fact still 0.92.2 :

$ sudo port install inkscape +quartz
--->  Computing dependencies for inkscape
--->  Fetching archive for inkscape
--->  Attempting to fetch inkscape-0.92.3_3+quartz.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/inkscape
--->  Attempting to fetch inkscape-0.92.3_3+quartz.darwin_15.x86_64.tbz2 from https://packages.macports.org/inkscape
--->  Attempting to fetch inkscape-0.92.3_3+quartz.darwin_15.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/inkscape
--->  Fetching distfiles for inkscape
--->  Verifying checksums for inkscape
--->  Extracting inkscape
--->  Applying patches to inkscape
--->  Configuring inkscape
--->  Building inkscape
--->  Staging inkscape into destroot
--->  Installing inkscape @0.92.3_3+quartz
--->  Deactivating inkscape @0.92.3_3+x11
--->  Cleaning inkscape
--->  Activating inkscape @0.92.3_3+quartz
--->  Cleaning inkscape
--->  Scanning binaries for linking errors
--->  No broken files found.
--->  No broken ports found.
$ port installed Inkscape
The following ports are currently installed:
  inkscape @0.92.3_3+quartz (active)
$ /opt/local/bin/inkscape --version
Inkscape 0.92.2 2405546, 2018-03-11

Change History (4)

comment:1 Changed 2 years ago by fdesar

I noticed the inkscape-devel port, which I presume should be the latest, is still 0.92.2...

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… removed
Description: modified (diff)
Owner: set to dbevans
Port: inkscape added; Inkscape removed
Status: newassigned
Summary: Port install of Inkscape 0.92.3_3 seems to be still 0.92.2inkscape @0.92.3_3 seems to be still 0.92.2

I can confirm both of the issues you're reporting.

comment:3 Changed 21 months ago by dbevans (David B. Evans)

In 66c18926d721fe188480c9efffad16098fa80d63/macports-ports (master):

inkscape-gkt3-devel: new port

  • recent snapshot of upstream development toward the 1.0 gtk3 port of inkscape.
  • now uses preferred cmake/ninja build
  • addresses a several outstanding inkscape/inkscape-devel issues

See #56806
See #56867

comment:4 Changed 21 months ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

In 614879abeef2c4a07dfad26e6bb5768f4a125dfd/macports-ports (master):

inkscape: update to version 0.92.4

  • now uses preferred cmake/ninja build
  • switch to cmake fixes display of version in Help/About

See #56806
Closes #56867

Note: See TracTickets for help on using tickets.