Opened 2 years ago

Last modified 20 months ago

#56889 assigned defect

libkdcraw does not build against libraw-0.19.0

Reported by: jjstickel (Jonathan Stickel) Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: mexon (Matthew Exon), gusbemacbe (Gustavo Reis)
Port: libkdcraw

Description

Recent update to libraw-0.19.0 breaks libkdcraw. Log attached. FYI, another distro bug report with perhaps some relevant information is at https://bugs.gentoo.org/659860.

Attachments (1)

main.log (82.7 KB) - added by jjstickel (Jonathan Stickel) 2 years ago.

Download all attachments as: .zip

Change History (15)

Changed 2 years ago by jjstickel (Jonathan Stickel)

Attachment: main.log added

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Cc: NicosPavlov removed
Keywords: libraw removed

comment:2 Changed 2 years ago by jwhowse4

I have encountered exactly the same problem.

comment:3 Changed 2 years ago by mexon (Matthew Exon)

Cc: mexon added

comment:4 Changed 2 years ago by NicosPavlov

Unfortunately, as indicated in the link you provided, there have been significant changes in libraw's API in version 0.19, that are not compatible with the rather old libkdcraw version we have, based on KDE4.

The changes in libkdcraw to use the new API were performed on version 18.08.0, which is already based on KF5, so that porting back the changes would probably be quite difficult.

comment:5 Changed 2 years ago by mexon (Matthew Exon)

Is it possible to revert libraw to something < 18.08.0?

I'm trying to install digikam, which requires libkdcraw.

Last edited 2 years ago by mexon (Matthew Exon) (previous) (diff)

comment:6 Changed 2 years ago by NicosPavlov

it is indeed possible to install older ports, as described in wiki:howto/InstallingOlderPort.

You should install libraw 0.18.12, which still possesses the older API.

Last edited 2 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:7 Changed 2 years ago by mexon (Matthew Exon)

Ah great, 0.18.12 installed no problem. Thanks for answering the newbie question!

Digikam still doesn't work, but I'll file a separate bug for that.

comment:8 Changed 2 years ago by RJVB (René Bertin)

Note that there's an official installer for digiKam's current version: https://www.digikam.org/download/

comment:9 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: gusbemacbe added

Has duplicate #57567.

comment:10 Changed 2 years ago by mexon (Matthew Exon)

@RJVB - uh... somehow I didn't notice that 🤣

I think I might actually have been trying and failing to get digikam working under macports for so long that the native version just wasn't working when I started, and I've been struggling this way ever since.

But yeah, the native version works great. Problem solved!

comment:11 Changed 21 months ago by AndreaCallia (Andrea Callia D'Iddio)

Any news about this? I wanted to report that, because of such issues, the following ports cannot be built as well.

  • gwenview
  • kdegraphics4

Moreover, since kdegraphics4 cannot be built, then Okular cannot open PDF files.

Last edited 21 months ago by AndreaCallia (Andrea Callia D'Iddio) (previous) (diff)

comment:12 in reply to:  11 Changed 20 months ago by jjstickel (Jonathan Stickel)

Replying to AndreaCallia:

Any news about this? I wanted to report that, because of such issues, the following ports cannot be built as well.

  • gwenview
  • kdegraphics4

Moreover, since kdegraphics4 cannot be built, then Okular cannot open PDF files.

I've come to the conclusion that KDE4 is dead. Unfortunately, KF5 on mac is really a mess. So it looks like we need to find alternatives to our favorite KDE apps and move on.

comment:13 Changed 20 months ago by NicosPavlov

Has duplicate #58092.

comment:14 Changed 20 months ago by NicosPavlov

Point taken for gwenview. I should indeed look at that one, which is a separate problem.

It is true that okular does not support PDF anymore, but that is not related. Kdegraphics4 is just a stub port. PDF support in Okular is based on Poppler, and qt4 support has been dropped in poppler quite some time ago.

Note: See TracTickets for help on using tickets.