Opened 3 years ago

Closed 3 years ago

#56891 closed defect (fixed)

lynis: Could not find languages directory (file: /opt/local/etc/lynis/languages/en)

Reported by: mf2k (Frank Schima) Owned by: newtonne
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: lynis

Description (last modified by mf2k (Frank Schima))

I am not able to run lynis. Is something missing or maybe setup instructions should be added?

$ lynis 
Could not find languages directory (file: /opt/local/etc/lynis/languages/en)

Change History (5)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:2 Changed 3 years ago by newtonne

Thanks for raising this. Looks like I forgot to stage an extra change I made to the reinplace regex. Will fix later today.

comment:3 Changed 3 years ago by mf2k (Frank Schima)

Any updates on this?

comment:4 Changed 3 years ago by newtonne

Just pushed an update to https://github.com/macports/macports-ports/pull/2315, which is awaiting review.

comment:5 Changed 3 years ago by newtonne <newtonne@…>

Resolution: fixed
Status: assignedclosed

In c8231d17c88ca2cc5ee9cf68bf0306c178536560/macports-ports (master):

lynis: Fix reinplace regex and add bash completion

  • Issue 56891 was caused by the reinplace regex being incorrect. I've

now fixed this so that the ${prefix}/etc/${name}/* paths are correct.

  • Also, just realised that they include a bash completion file so I've

installed that now too.

Fixes: #56891

Note: See TracTickets for help on using tickets.