Opened 2 years ago

Closed 13 months ago

#56956 closed update (fixed)

julia @0.6.2_2: update to 1.0.0

Reported by: l2dy (Zero King) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jjstickel (Jonathan Stickel), mf2k (Frank Schima), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez), rurban (Reini Urban), essandess (Steve Smith)
Port: julia

Description


Attachments (4)

julia_Portfile.diff (3.3 KB) - added by jjstickel (Jonathan Stickel) 2 years ago.
main.log (177.6 KB) - added by jjstickel (Jonathan Stickel) 2 years ago.
Portfile-v1.2.0rc2.diff (4.4 KB) - added by krystophny (Christopher Albert) 14 months ago.
Portfile-v1.2.0rc2 (5.0 KB) - added by krystophny (Christopher Albert) 14 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 2 years ago by jjstickel (Jonathan Stickel)

Cc: jjstickel added

Changed 2 years ago by jjstickel (Jonathan Stickel)

Attachment: julia_Portfile.diff added

Changed 2 years ago by jjstickel (Jonathan Stickel)

Attachment: main.log added

comment:2 Changed 2 years ago by jjstickel (Jonathan Stickel)

I've made some progress with updating the Portfile for 1.0.0 (patch attached). But I've run into this error (log attached):

    JULIA usr/lib/julia/sys-o.a
Generating precompile statements... 762 generated in  51.547380 seconds
Illegal inttoptr
	  %scevgep9 = ptrtoint i32 addrspace(13)* %scevgep to i64
Illegal inttoptr
	  %scevgep1011 = ptrtoint i32 addrspace(13)* %scevgep10 to i64

signal (6): Abort trap: 6
in expression starting at no file:0
__pthread_kill at /usr/lib/system/libsystem_kernel.dylib (unknown line)
Allocations: 57642517 (Pool: 57631597; Big: 10920); GC: 126
/bin/sh: line 1: 15010 Abort trap: 6           /opt/local/var/macports/build/_Users_Shared_install_macports_ports_lang_julia/julia/work/julia/usr/bin/julia -O3 -C "native" --output-o /opt/local/var/macports/build/_Users_Shared_install_macports_ports_lang_julia/julia/work/julia/usr/lib/julia/sys-o.a.tmp --startup-file=no --warn-overwrite=yes --sysimage /opt/local/var/macports/build/_Users_Shared_install_macports_ports_lang_julia/julia/work/julia/usr/lib/julia/sys.ji /opt/local/var/macports/build/_Users_Shared_install_macports_ports_lang_julia/julia/work/julia/contrib/generate_precompile.jl /opt/local/var/macports/build/_Users_Shared_install_macports_ports_lang_julia/julia/work/julia/usr/lib/julia/sys.ji
*** This error is usually fixed by running `make clean`. If the error persists, try `make cleanall`. ***
make[2]: *** [/opt/local/var/macports/build/_Users_Shared_install_macports_ports_lang_julia/julia/work/julia/usr/lib/julia/sys-o.a] Error 1

From a little google research, I think it has to do with LLVM. This looks similar:

https://www.mail-archive.com/debian-bugs-closed@lists.debian.org/msg597339.html

I've spent all the time I can on it for now.

comment:3 Changed 2 years ago by mf2k (Frank Schima)

Cc: mf2k added

comment:4 Changed 21 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:5 Changed 20 months ago by rurban (Reini Urban)

Cc: rurban added

comment:6 Changed 19 months ago by mf2k (Frank Schima)

Owner: seanfarley deleted

Changed 14 months ago by krystophny (Christopher Albert)

Attachment: Portfile-v1.2.0rc2.diff added

Changed 14 months ago by krystophny (Christopher Albert)

Attachment: Portfile-v1.2.0rc2 added

comment:7 Changed 14 months ago by krystophny (Christopher Albert)

The problem is most likely the use of the unpatched system LLVM. Julia requires special patches and recommends to do a custom build of LLVM dedicated to julia, see Docs.

I've added a Portfile in the attachments that works for me in version 1.2.0rc2 . Since this one is to be released soon, I propose to wait for 1.2.0 and add it to macports, or otherwise change it to version 1.1 before.

comment:8 Changed 14 months ago by mf2k (Frank Schima)

Thanks! Per the guidelines, please instead attach a unified diff of the Portfile so we can easily see what changes you are proposing. Or better yet, submit a pull request.

comment:9 Changed 13 months ago by ryandesign (Ryan Schmidt)

Cc: essandess added
Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.