Opened 3 years ago

Last modified 3 months ago

#56989 reopened defect

Sundials prevents install of Octave

Reported by: dershow Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: Schamschula (Marius Schamschula), murrayeisenberg@…
Port: octave

Description

Octave requires Sundials2, which conflicts with the Sundials port. Sundials (version 3) is required for some other ports. This was discussed in this thread: https://lists.macports.org/pipermail/macports-users/2018-June/045227.html

The thread included a proposed patch that would add a variant to octave of -sundials2 I was able to locally build it that way, and it worked for me with octave 4.4.0_5, but the patch would need a change due to the upgrade to octave 4.4.0_6. I would encourage that this variant be added to octave to allow it to coexist with Sundials.

Change History (4)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Cc: MarcusCalhoun-Lopez removed
Owner: set to MarcusCalhoun-Lopez
Status: newassigned

comment:2 Changed 3 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed

In b20ddd5fc31b0f53e42dbc310586856390643175/macports-ports (master):

octave: make SUNDIALS support optional

Fixes #56989

comment:3 Changed 3 months ago by lpn25

Resolution: fixed
Status: closedreopened

Similar problem when trying to update octave from 6.2.0_0 to 6.2.0_1:

Error: Can't install sundials because conflicting ports are active: sundials2

To fix it, I had to explicitly put -sundials (somehow it was on when octave was installed but wasn't causing issues until now)

Last edited 3 months ago by lpn25 (previous) (diff)

comment:4 Changed 3 months ago by Schamschula (Marius Schamschula)

It's telling you that you have to deactivate sundials2 before upgrading octave.

The reason it worked before its that though octave found sundials2, sundials did not provide there required symbols, and, thus, octave was build w/o sundials support.

Note: See TracTickets for help on using tickets.