Opened 7 months ago

Closed 2 months ago

Last modified 2 months ago

#56990 closed defect (duplicate)

py35-pyqt5: error: no member named 'chopped' in 'QByteArray'

Reported by: hansgans Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: py-pyqt5

Description

Compilation of the port fails with:

sipQtCoreQByteArray.cpp:2263:48: error: no member named 'chopped' in 'QByteArray'

I suspect it has to do with the version of qt (in my case qt59) that is installed. I attached the full log file.

Attachments (1)

log (421.0 KB) - added by hansgans 7 months ago.
log

Download all attachments as: .zip

Change History (4)

Changed 7 months ago by hansgans

Attachment: log added

log

comment:1 Changed 7 months ago by ryandesign (Ryan Schmidt)

Owner: set to mamoll
Port: py-pyqt5 added; py35-pyqt5 removed
Status: newassigned
Summary: Compilation failspy35-pyqt5: error: no member named 'chopped' in 'QByteArray'

We've seen this problem before with qt59; see #56601.

The difference here is that while #56601 is about systems which cannot use versions of Qt later than qt59, your log shows you are on High Sierra, so you should be using the qt5 port instead, which will provide Qt version 5.10.x, with which pyqt5 is compatible.

comment:2 Changed 2 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: duplicate
Status: assignedclosed

I believe this ticket can be closed since it is a duplicate of #56601.
The user also has the option of using a later Qt version.

comment:3 Changed 2 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added
Note: See TracTickets for help on using tickets.