Changes between Initial Version and Version 1 of Ticket #56996, comment 7


Ignore:
Timestamp:
Aug 30, 2018, 3:22:52 PM (3 years ago)
Author:
cjones051073 (Chris Jones)
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #56996, comment 7

    initial v1  
    11cctools defaults to using the xcode variant when it detects an Xcode version 9 or newer. This variant means the port simply installs wrapper scripts that use the Xcode supplied toolchain, instead of building its own. The supplied log shows that Xcode 9.2 is being used on macOS 10.12 so this is why the xcode variant is being activated. This is what has changed since June, as prior to this cctools was installing its own tool kit that was based on Xcode 8 (and cannot be updated until Apple open sources the required tools). This is why the Xcode variant came about, as using tools older than the Xcode compiler was causing issues in a few places.
    22
    3 Do we really need libgcc45 on macOS 10.12 ? Searching the ports tree nothing is depending on it, so I would suggest just obsoleting this port on 10.12, as it is own 10.13. If a gcc compiler is required, use gcc8 instead...
     3Do we really need libgcc45 on macOS 10.12 ? Searching the ports tree nothing is depending on it, so I would suggest just obsoleting this port on 10.12, as it is on 10.13. If a gcc compiler is required, use gcc8 instead...