Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#57077 closed defect (duplicate)

Error: Failed to build gcc47: on 10.12.6 with Xcode 9.0.1: error: non-local symbol required in directive

Reported by: nbolyard Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc:
Port: gcc47

Description

After hours of building, the command "sudo port install gcc47 +universal" failed with the error message "Error: Failed to build gcc47: command execution failed". The file /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_gcc47/gcc47/main.log is attached.

Story: my MacOS was updated to Sierra 10.12.6. I completely wiped out the old MacPorts by following the instructions in https://guide.macports.org/chunked/installing.macports.uninstalling.html including the rm -rf step. Then I installed MacPorts-252-10.12-Sierra.pkg. Then as the first command, I tried "sudo port install gcc47 +universal". It built for HOURS, then it stopped with the error message shown above.

Now I'm stuck. Please help me to get this installation completed.

Attachments (1)

main.log.Z (5.2 MB) - added by nbolyard 3 years ago.
Compressed version of the log of the failed install attempt.

Change History (5)

Changed 3 years ago by nbolyard

Attachment: main.log.Z added

Compressed version of the log of the failed install attempt.

comment:1 Changed 3 years ago by kencu (Ken)

This is our bad. gcc versions less than 5.0 are known to fail on newer systems. Very sorry that our error messages are not up to date on this. I will try to update those error messages ASAP so this doesn't happen to anyone else.

I'll be closing this as a duplicate of other tickets which mention the same thing, but thank you for taking the time to place your report, and once again, sorry about our out-of-date error message. -- Best, Ken

comment:2 Changed 3 years ago by kencu (Ken)

Resolution: duplicate
Status: newclosed

comment:3 Changed 3 years ago by kencu (Ken)

Summary: Error: Failed to build gcc47: command execution failedError: Failed to build gcc47: on 10.12.6 with Xcode 9.0.1: error: non-local symbol required in directive
:info:build   :17   :  error: non-local symbol required in directive   
:info:build                     . n o^
:info:build _dead_strip L_OBJC_Module

comment:4 Changed 3 years ago by kencu (Ken)

duplicate of 56996

Note: See TracTickets for help on using tickets.