Opened 2 years ago

Closed 2 years ago

#57084 closed defect (duplicate)

pinentry-mac @ 0.9.4 does not build on macOS Mojave 10.14

Reported by: ylluminarious (George Plymale II) Owned by: Ionic (Mihai Moldovan)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: mojave Cc:
Port: pinentry-mac

Description

pinentry-mac fails to install on the macOS Mojave 10.14 beta. Obviously, this is most likely to affect users who try to install gnupg2. NB: gnupg2 fails to install on Mojave as a result of this.

Here is the short error message:

--->  Fetching archive for pinentry-mac
--->  Attempting to fetch pinentry-mac-0.9.4_0.darwin_18.x86_64.tbz2 from https://packages.macports.org/pinentry-mac
--->  Attempting to fetch pinentry-mac-0.9.4_0.darwin_18.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/pinentry-mac
--->  Attempting to fetch pinentry-mac-0.9.4_0.darwin_18.x86_64.tbz2 from http://nue.de.packages.macports.org/pinentry-mac
--->  Fetching distfiles for pinentry-mac
--->  Attempting to fetch pinentry-mac-0.9.4.tar.gz from https://distfiles.macports.org/pinentry-mac
--->  Verifying checksums for pinentry-mac
--->  Extracting pinentry-mac
--->  Configuring pinentry-mac
--->  Building pinentry-mac
Error: Failed to build pinentry-mac: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_pinentry-mac/pinentry-mac/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gnupg2 failed

I am attaching the log file as well. The specific OS version is:

ProductName:	Mac OS X
ProductVersion:	10.14
BuildVersion:	18A377a

Also, I am using Xcode 10 beta 6 although Xcode 9.4.1 is installed as well. More info on my current setup is available at #57080.

Attachments (1)

pinentry-mac.log (187.5 KB) - added by ylluminarious (George Plymale II) 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by ylluminarious (George Plymale II)

Attachment: pinentry-mac.log added

comment:1 Changed 2 years ago by ylluminarious (George Plymale II)

Version: 2.5.3

comment:2 Changed 2 years ago by jmroot (Joshua Root)

Owner: set to Ionic
Status: newassigned

comment:3 Changed 2 years ago by Ionic (Mihai Moldovan)

Resolution: duplicate
Status: assignedclosed

Duplicate of #57178 (really the other way around, but since pmetzger already made changes...)

Note: See TracTickets for help on using tickets.