Opened 6 months ago

Closed 3 days ago

#57108 closed defect (duplicate)

Failed to upgrade opencv @3.2.0+contrib+python36 to opencv @3.4.1_2 Mac OSX Sierra

Reported by: fmw42 (Fred Weinhaus) Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: Blokkendoos (Johan)
Port: opencv

Description (last modified by ryandesign (Ryan Schmidt))

I first did sudo port selfupdate. Then I upgraded all my outdate ports except opencv, which failed. I then tried sudo port clean opencv, which failed. I then tried to install opencv manually via sudo port install opencv +contrib+python36

My steps and log file are attached. I am on Mac INTEL Mini OSX Sierra 10.12.6.

Model Name:	Mac mini
  Model Identifier:	Macmini7,1
  Processor Name:	Intel Core i5
  Processor Speed:	2.8 GHz
  Number of Processors:	1
  Total Number of Cores:	2
  L2 Cache (per Core):	256 KB
  L3 Cache:	3 MB
  Memory:	8 GB
  Boot ROM Version:	MM71.0232.B00
  SMC Version (system):	2.24f32
  Serial Number (system):	C07TJ0K8G1J2
  Hardware UUID:	EB20C4A5-C2A3-5D2A-8C7C-B23E5E64FE83

Attachments (2)

macports error - opencv.txt (1.0 MB) - added by fmw42 (Fred Weinhaus) 6 months ago.
steps and log file
opencv+python37.txt (27.9 KB) - added by fmw42 (Fred Weinhaus) 3 months ago.
install opencv +python37

Download all attachments as: .zip

Change History (12)

Changed 6 months ago by fmw42 (Fred Weinhaus)

Attachment: macports error - opencv.txt added

steps and log file

comment:1 Changed 6 months ago by jmroot (Joshua Root)

Keywords: opencv contrib python36 removed
Owner: set to stromnov
Status: newassigned

comment:2 Changed 3 months ago by fmw42 (Fred Weinhaus)

Any updates on when this might get fixed? It is still an issue with the latest MacPorts and OpenCV port as of 11/8/2018

comment:3 Changed 3 months ago by kencu (Ken)

The +contrib variant is broken:

:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.cc:4:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:12:2: error: This file was generated by a newer version of protoc which is
:info:build #error This file was generated by a newer version of protoc which is
:info:build  ^
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:13:2: error: incompatible with your Protocol Buffer headers.  Please update
:info:build #error incompatible with your Protocol Buffer headers.  Please update
:info:build  ^
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:14:2: error: your headers.
:info:build #error your headers.
:info:build  ^
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:23:10: fatal error: 'google/protobuf/arena.h' file not found
:info:build #include <google/protobuf/arena.h>

Looks like an upstream bug, to be sure.

Can you use opencv without the +contrib variant? It's not a default variant anyway and who knows when (if ever) it might be fixed upstream.

comment:4 Changed 3 months ago by fmw42 (Fred Weinhaus)

Thanks for the reply. I was using SIFT from the contrib. But I will try without the contrib and see if I can even get OpenCV installed without it. Let you know what happens.

Any idea if this is an OpenCV issue or MacPorts or cmake issues?

comment:5 Changed 3 months ago by sharris40 (Spencer Harris)

Would changing the dependency on protobuf-cpp to protobuf3-cpp in the Portfile fix this?

Changed 3 months ago by fmw42 (Fred Weinhaus)

Attachment: opencv+python37.txt added

install opencv +python37

comment:6 Changed 3 months ago by fmw42 (Fred Weinhaus)

Today, I upgrade MacPorts and my outdated ports. I then tried sudo port install opencv +python37 (without +contrib). But it failed as follows:

sudo port install opencv +python37
--->  Computing dependencies for opencv
--->  Fetching archive for opencv
--->  Attempting to fetch opencv-3.4.3_1+python37.darwin_16.x86_64.tbz2 from https://packages.macports.org/opencv
--->  Attempting to fetch opencv-3.4.3_1+python37.darwin_16.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/opencv
--->  Attempting to fetch opencv-3.4.3_1+python37.darwin_16.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/opencv
--->  Fetching distfiles for opencv
--->  Verifying checksums for opencv
--->  Extracting opencv
--->  Applying patches to opencv
--->  Configuring opencv
--->  Building opencv
--->  Staging opencv into destroot
--->  Installing opencv @3.4.3_1+python37
--->  Deactivating opencv @3.2.0_1+contrib+python36
--->  Cleaning opencv
--->  Activating opencv @3.4.3_1+python37
--->  Cleaning opencv
--->  Scanning binaries for linking errors
--->  Found 14 broken files, matching files to ports     
Warning: No port gegl found in the index; can't rebuild
--->  Broken files found, but all associated ports are not in the index and so cannot be rebuilt.

But I do have installed gegl-0.4 @0.4.12_2+x11 (active)

Can you suggest what I can do about this?

See the attachment for the details and all my installed ports.

Thanks.

Last edited 3 days ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:7 Changed 3 months ago by Blokkendoos (Johan)

Cc: Blokkendoos added

comment:8 Changed 3 days ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:9 in reply to:  6 Changed 3 days ago by ryandesign (Ryan Schmidt)

Replying to fmw42:

Today, I upgrade MacPorts and my outdated ports. I then tried sudo port install opencv +python37 (without +contrib). But it failed as follows:

First, note that opencv installed successfully. After installation, MacPorts checks all installed ports for problems, which is when it found a problem with a different port.

sudo port install opencv +python37
--->  Computing dependencies for opencv
--->  Fetching archive for opencv
--->  Attempting to fetch opencv-3.4.3_1+python37.darwin_16.x86_64.tbz2 from https://packages.macports.org/opencv
--->  Attempting to fetch opencv-3.4.3_1+python37.darwin_16.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/opencv
--->  Attempting to fetch opencv-3.4.3_1+python37.darwin_16.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/opencv
--->  Fetching distfiles for opencv
--->  Verifying checksums for opencv
--->  Extracting opencv
--->  Applying patches to opencv
--->  Configuring opencv
--->  Building opencv
--->  Staging opencv into destroot
--->  Installing opencv @3.4.3_1+python37
--->  Deactivating opencv @3.2.0_1+contrib+python36
--->  Cleaning opencv
--->  Activating opencv @3.4.3_1+python37
--->  Cleaning opencv
--->  Scanning binaries for linking errors
--->  Found 14 broken files, matching files to ports     
Warning: No port gegl found in the index; can't rebuild
--->  Broken files found, but all associated ports are not in the index and so cannot be rebuilt.

But I do have installed gegl-0.4 @0.4.12_2+x11 (active)

Can you suggest what I can do about this?

Yes, you have the "gegl-0.4" port installed. But that is different from the "gegl" port mentioned in the error message. The gegl port was deleted from MacPorts because it is no longer needed. If you still have it installed, uninstall it.

comment:10 in reply to:  3 Changed 3 days ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Replying to kencu:

The +contrib variant is broken:

Duplicate of #56349.

Note: See TracTickets for help on using tickets.