Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#57110 closed defect (fixed)

xorg-server @1.18.4_3 does not build on PPC Tiger, Mac Os X 10.4.11, because " Something went wrong bootstrapping makefile fragments"

Reported by: ballapete (Peter Dyballa) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: tiger Cc:
Port: xorg-server

Description

config.status: creating include/kdrive-config.h
config.status: creating include/version-config.h
config.status: executing depfiles commands
config.status: error: in `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server/xorg-server/work/xorg-server-1.18.4':
config.status: error: Something went wrong bootstrapping makefile fragments
    for automatic dependency tracking.  Try re-running configure with the
    '--disable-dependency-tracking' option to at least be able to build
    the package (albeit without support for automatic dependency tracking).
See `config.log' for more details
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server/xorg-server/work/xorg-server-1.18.4" && ./configure --prefix=/opt/local --with-apple-applications-dir=/Applications/MacPorts --with-bundle-id-prefix=org.macports --without-dtrace --without-doxygen --without-fop --without-xmlto --disable-devel-docs --with-sha1=CommonCrypto --disable-dri2 --disable-dri3 
Exit code: 1
Error: Failed to configure xorg-server, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server/xorg-server/work/xorg-server-1.18.4/config.log

Attachments (1)

main.log (68.6 KB) - added by ballapete (Peter Dyballa) 3 years ago.
Main.log from PPC Tiger

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by ballapete (Peter Dyballa)

Attachment: main.log added

Main.log from PPC Tiger

comment:1 Changed 3 years ago by ballapete (Peter Dyballa)

By adding --disable-dependency-tracking to the configure options the configuration stage finishes and build starts, which succeeds.

Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

We've seen this Try re-running configure with the '--disable-dependency-tracking' option message a lot lately. I don't know why.

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: jeremyhu@… removed
Owner: set to jeremyhu
Status: newassigned

comment:4 Changed 3 years ago by jmroot (Joshua Root)

Please attach the config.log mentioned in the message.

comment:5 Changed 2 years ago by SerpentChris (Chris Calderon)

I believe I have the same exact error on my ppc Mac running OS X 10.4.11 Tiger. Is it possible to add attachments to comments, or should I make a new ticket for this? I have a main.log and config.log to provide.

comment:6 Changed 2 years ago by kencu (Ken)

Resolution: fixed
Status: assignedclosed

comment:7 Changed 2 years ago by kencu (Ken)

This error is nicely described here <https://github.com/bitcoin/bitcoin/issues/14404> and it appears similar.

It looks like something changed in a recent autotools upgrade at 1.16, which would be why we're seeing it much more lately on Tiger.

It also looks like it could be fixed by forcing a newer make like gmake, which is why we're only seeing it on Tiger.

I really would like to just force all MacPorts' builds on Tiger to use gmake without having to specify it for every single port. Perhaps if we had the gmake port install gmake as make or with a link to make during installation on Tiger we would make everyone's life much easier. Especially mine.

Note: See TracTickets for help on using tickets.