Opened 2 years ago

Closed 2 years ago

#57167 closed defect (fixed)

poppler-qt5: CMake-related build failure on 10.8

Reported by: mojca (Mojca Miklavec) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: michaelld (Michael Dickens), yan12125 (Chih-Hsuan Yen)
Port: poppler-qt5

Description

Build of poppler on 10.8 fails in a pretty absurd way:

-- Configuring done
CMake Error in qt5/src/CMakeLists.txt:
  No known features for CXX compiler

  "Clang"

  version 5.0.2.

https://build.macports.org/builders/ports-10.8_x86_64_legacy-builder/builds/71069

Weird enough it works on 10.7.

Change History (6)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

It's easy enough to reproduce this on a newer system such as High Sierra with:

sudo port configure poppler-qt5 configure.compiler=macports-clang-6.0

comment:2 Changed 2 years ago by yan12125 (Chih-Hsuan Yen)

Cc: yan12125 added

comment:3 Changed 2 years ago by kencu (Ken)

Looks like a known issue. See:

<https://stackoverflow.com/questions/38027292/configure-a-qt5-5-7-application-for-android-with-cmake/40256862#40256862>

and

<https://bugreports.qt.io/browse/QTBUG-54666>

and in particular

<https://bugreports.qt.io/browse/QTBUG-57886>

I tried the suggested workaround, it it got past the initial issue, but then it died later with unrecognized compiler characteristics.

This issue seems to be happening in a number of different tickets, and we should probably condense it into one to follow it along.

comment:4 Changed 2 years ago by yan12125 (Chih-Hsuan Yen)

This should be fixed with a simple patch for poppler:

https://github.com/macports/macports-ports/pull/3098#issuecomment-443080512

comment:5 Changed 2 years ago by kencu (Ken)

Ah, just came down to improperly-written CMakeLists.txt files in the end. Seems a common enough problem out there that I'm surprised to see it still on the qt bug tracker. The cmake docs are clear enough that the requirements have to come first...good job nailing it.

comment:6 Changed 2 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

In 652319c36aed7b50ae11beef623b0f1cb66a914c/macports-ports (master):

poppler-qt5: fix cmake/qt5 configuration failures with non-Apple clang

Closes #57167

Note: See TracTickets for help on using tickets.