Opened 6 months ago

Closed 6 months ago

#57170 closed defect (fixed)

macvim +huge fails to build under Xcode 10

Reported by: MaurizioLoreti Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: xcode10 Cc: sitrucz1 (Curtis Matz), slarew, lperry (Perry Lee), mtn88 (Max), skymoo (Adam Mercer), jgosmann (Jan Gosmann), libsystem-ethan, rlhamil, gorticus (Jason Mitchell), inyeollee
Port: MacVim

Description

After upgrading to Mojave, I deleted all installed ports, reinstalled macports from source and typed sudo port install macvim +huge. The command failed; the log is in attachment. TIA for any help!

Attachments (1)

main.log (123.4 KB) - added by MaurizioLoreti 6 months ago.
Log file

Download all attachments as: .zip

Change History (25)

Changed 6 months ago by MaurizioLoreti

Attachment: main.log added

Log file

comment:1 Changed 6 months ago by moyang (Moyang Wang)

same here

Last edited 6 months ago by moyang (Moyang Wang) (previous) (diff)

comment:2 Changed 6 months ago by mtn88 (Max)

same problem here. macvim failes to build on macOS Mojave with both of the following commands:

port install macvim +huge
port install macvim +big

comment:3 Changed 6 months ago by mf2k (Frank Schima)

Cc: raimue removed
Owner: set to raimue
Port: MacVim added; macvim removed
Status: newassigned

comment:4 Changed 6 months ago by mf2k (Frank Schima)

See also #57091.

comment:5 Changed 6 months ago by raimue (Rainer Müller)

Keywords: mojave added

I have not yet upgraded to Mojave, so I cannot test this right now. Sorry.

It is very likely caused by changes in Xcode 10. Looks like Apple developers did not know how to properly look up the home directory of a user and hardcoded the /Users path? I have no idea why else it would want to store things at /Users/macports/....

comment:6 Changed 6 months ago by kencu (Ken)

This worked:

# Old pre-compiled headers could influence build, #26723
build.args          XCODEFLAGS="CACHE_ROOT=${workpath}/caches"

+ # this port does not build with the new xcode build system at present
+ if {[vercmp ${xcodeversion} 10.0] >= 0} {
+ build.args    XCODEFLAGS="CACHE_ROOT=${workpath}/caches -UseNewBuildSystem=NO"
+ }
$ port -v installed macvim
The following ports are currently installed:
  MacVim @8.1.snapshot151_0+huge (active) platform='darwin 18' archs='x86_64' date='2018-09-30T17:12:41-0700'

comment:7 Changed 6 months ago by kencu (Ken)

However, it doesn't work right on my system. The macvim window wildly refreshes black and white with any mouse movement in the window. Possibly other errors to be discovered.

Builds -- but is unusable.

Last edited 6 months ago by kencu (Ken) (previous) (diff)

comment:8 Changed 6 months ago by MaurizioLoreti

In the meanwhile, I downloaded the .dmg file from https://github.com/macvim-dev/macvim/releases and installed MacVim from there. I will wait for a fix coming...

comment:9 Changed 6 months ago by sitrucz1 (Curtis Matz)

Cc: sitrucz1 added

comment:10 Changed 6 months ago by sitrucz1 (Curtis Matz)

Cc: sitrucz1 removed

comment:11 Changed 6 months ago by sitrucz1 (Curtis Matz)

Cc: sitrucz1 added

comment:12 Changed 6 months ago by slarew

Cc: slarew added

comment:13 Changed 6 months ago by lperry (Perry Lee)

Cc: lperry added

comment:14 Changed 6 months ago by mtn88 (Max)

Cc: mtn88 added

comment:15 Changed 6 months ago by skymoo (Adam Mercer)

Cc: skymoo added

comment:16 Changed 6 months ago by jgosmann (Jan Gosmann)

Cc: jgosmann added

comment:17 Changed 6 months ago by libsystem-ethan

Cc: libsystem-ethan added

comment:18 Changed 6 months ago by rlhamil

Cc: rlhamil added

comment:19 Changed 6 months ago by gorticus (Jason Mitchell)

Cc: gorticus added

comment:20 Changed 6 months ago by kencu (Ken)

So there are two different issues with MacVim. The build failure is fixed by the small Portfile bit above, which we might as well commit.

+ # this port does not build with the new xcode build system at present
+ if {[vercmp ${xcodeversion} 10.0] >= 0} {
+ build.args    XCODEFLAGS="CACHE_ROOT=${workpath}/caches -UseNewBuildSystem=NO"
+ }

MacVim is unusable after that build however. There are build issues against the 10.14 SDK being tracked here <https://github.com/macvim-dev/macvim/issues/751> and for which there are temporary workarounds while a fix is being finalized.

comment:22 Changed 6 months ago by mf2k (Frank Schima)

Keywords: xcode10 added; mojave removed
Summary: macvim +huge fails to build under OS X Mojavemacvim +huge fails to build under Xcode 10

comment:23 Changed 6 months ago by inyeollee

Cc: inyeollee added

comment:24 Changed 6 months ago by ken-cunningham-webuse

Resolution: fixed
Status: assignedclosed

In f830225333a87404f5db617984863ed0cff29912/macports-ports (master):

macvim: fix build with Xcode10

closes: #57170

Note: See TracTickets for help on using tickets.