Opened 2 years ago

Closed 4 months ago

#57179 closed defect (fixed)

openldap @2.4.46: Build fails with libressl

Reported by: mtn88 (Max) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: openldap

Description

Please see attached log file

Attachments (1)

openldap-main.log (329.8 KB) - added by mtn88 (Max) 2 years ago.

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by mtn88 (Max)

Attachment: openldap-main.log added

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Port: gnupg2 removed

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Summary: openldap @2.4.46-universal: Fails to build on macOS Mojave (10.14)openldap @2.4.46l: Build fails with libressl

openldap builds fine for me on macOS Mojave with openssl, so presumably the problem is that you are using libressl instead; some of the missing symbols mentioned in the log are openssl symbols.

comment:3 Changed 2 years ago by ryandesign (Ryan Schmidt)

Summary: openldap @2.4.46l: Build fails with libresslopenldap @2.4.46: Build fails with libressl

comment:4 in reply to:  2 Changed 2 years ago by mtn88 (Max)

Replying to ryandesign:

openldap builds fine for me on macOS Mojave with openssl, so presumably the problem is that you are using libressl instead; some of the missing symbols mentioned in the log are openssl symbols.

I can confirm that building against openssl works fine on Mojave.

comment:5 Changed 4 months ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

I think this got fixed somewhere along the way: I was able to build openldap 2.4.48 against libressl 2.8.3 (on macOS 10.13.6 with Xcode 9.4.1) with no changes needed.

Note: See TracTickets for help on using tickets.