#57228 closed defect (invalid)

upgrading or installing gmp fails with Mac OSX 10.14 Mojave

Reported by: manulcaux Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: gmp

Description (last modified by jmroot (Joshua Root))

I upgraded my Mac OS to Mojave, then installed the MacPorts-2.5.4-10.14-Mojave package and tried to upgrade all my ports.

I have a failure with gmp, that none of the advices given on the web site allow to solve.

Here is the error I get :

[macp2052:~] caux% sudo port upgrade outdated
--->  Fetching distfiles for gmp
--->  Verifying checksums for gmp
--->  Extracting gmp
--->  Applying patches to gmp
--->  Configuring gmp
--->  Building gmp
Error: Failed to build gmp: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/main.log for details.
Error: Problem while installing gmp
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

I attach the /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/main.log Desktop/main.log file.

Attachments (2)

main.log (333.7 KB) - added by manulcaux 22 months ago.
main.2.log (342.2 KB) - added by glesur (Geoffroy Lesur) 22 months ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_distfiles.macports.org_ports_devel_gmp/gmp/main.log

Download all attachments as: .zip

Change History (13)

Changed 22 months ago by manulcaux

Attachment: main.log added

comment:1 Changed 22 months ago by jmroot (Joshua Root)

Description: modified (diff)
Milestone: MacPorts 2.6.0
Owner: set to MarcusCalhoun-Lopez
Status: newassigned
Type: updatedefect

comment:2 Changed 22 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

I cannot seem to reproduce this error, but it looks like the problem is with ${prefix}/bin/ranlib.
What is the output of port installed cctools?

comment:3 Changed 22 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: assignedclosed

Since there is no response, I am closing this.
Please feel free to reopen if additional information becomes available.

comment:4 Changed 22 months ago by bergerb-com

Hello, I got pretty much the same error. I tried installing gnuradio. The dependency gmp failed to build. Then I tried to install gnuradio without the dependency gmp, since the installation worked with brew:

sudo port install depof:gnuradio and not gmp

I worked my way through all the sub-dependencies until I saw something related to cctools and remembered this ticket.

The current output of port installed cctools is

The following ports are currently installed:
  cctools @895_7+llvm50
  cctools @895_7+xcode (active)

I am pretty sure, that before it was working, only the first line was there.

comment:5 Changed 22 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Please run sudo port clean gmp, run sudo port install gmp.
If the build fails, please attach the main.log file.

comment:6 Changed 22 months ago by bergerb-com

gmp built correctly and is now installed. I got exactly the same error on line 1457 yesterday. I'm sorry, I did not save the log.

https://trac.macports.org/attachment/ticket/57228/main.log#L1457

As I said, I think the output of port installed cctools was only

The following ports are currently installed:
  cctools @895_7+llvm50

Is there a way to switch the active cctools? To try to reproduce this error?

Changed 22 months ago by glesur (Geoffroy Lesur)

Attachment: main.2.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_distfiles.macports.org_ports_devel_gmp/gmp/main.log

comment:7 Changed 22 months ago by glesur (Geoffroy Lesur)

Resolution: worksforme
Status: closedreopened

Same issue here. I have an upgraded osx 10.14.0 from 10.13. I have cleaned all of the installed ports, upgraded macports to 2.5.4, and now trying to install gcc8. I run into trouble when it compiles gmp:

gag8207:libcxx glesur$ sudo port clean gmp
Password:
--->  Cleaning gmp
gag8207:libcxx glesur$ sudo port install gmp
--->  Fetching distfiles for gmp
--->  Verifying checksums for gmp
--->  Extracting gmp
--->  Applying patches to gmp
--->  Configuring gmp
--->  Building gmp
Error: Failed to build gmp: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_distfiles.macports.org_ports_devel_gmp/gmp/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gmp failed

The log file shows the same ranlib error as first user (see attachement). cctools is

gag8207:libcxx glesur$ port installed cctools
The following ports are currently installed:
  cctools @895_4+llvm50 (active)
gag8207:libcxx glesur$ 

comment:8 Changed 22 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

The problem seems to be your cctools.
Installing cctools with the variant +llvm50 should not even be possible with Xcode 9 or greater.
There is code that is supposed to prevent it.
You mentioned that you "cleaned all of the installed ports" when you updated your OS, but did you reinstall all of the ports as required in the migration page?
If not, you will keep running into these kinds of problems.

Just to test this particular issue, you can use --enforce-variants to reinstall cctools.

comment:9 Changed 22 months ago by glesur (Geoffroy Lesur)

Agreed there is a problem with my cctools. For some reason, I don't see any xcode variant of cctools. I'm now restarting from scratch. Uninstalled all ports and manually rm macports directory. I'll keep you posted.

comment:10 Changed 22 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Since this seems to be a cctools issue, I will close this for now.
Please reopen if further information becomes available.

comment:11 Changed 22 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.