Opened 15 years ago

Closed 15 years ago

#5723 closed defect (fixed)

BUG: p7zip does not run

Reported by: ruyon@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: josh_root@…
Port:

Description

On my Powerbook(Mac OS X 10.4.3, ppc, g4, darwinport 1.102), the port 'p7zip' builds and installs succesfully, but fails to run. The following are the output.

Fina:~ ruyon$ 7za dyld: lazy symbol binding failed: lazy pointer not found dyld: lazy pointer not found Trace/BPT trap

Attachments (1)

Portfile.patch (421 bytes) - added by josh_root@… 15 years ago.
suggested fix

Download all attachments as: .zip

Change History (14)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to toby@…
Summary: p7zip does not runBUG: p7zip does not run

comment:2 Changed 15 years ago by toby@…

Works for me....

comment:3 Changed 15 years ago by toby@…

severity: majornormal

comment:4 Changed 15 years ago by toby@…

Resolution: worksforme
Status: newclosed

comment:5 Changed 15 years ago by narf_tm@…

I am having the same issue with p7zip 4.30_0 using the same configuration as the bug reporter. Can you please look into the issue again?

Console shows: Dec 13 23:45:41 * crashdump[1320]: 7za crashed Dec 13 23:45:41 * crashdump[1320]: crash report written to: /Users/*/Library/Logs/ CrashReporter/7za.crash.log


Crash log shows:

Host Name: * Date/Time: 2005-12-13 23:45:41.340 -0600 OS Version: 10.4.3 (Build 8F46) Report Version: 3

Command: 7za Path: /opt/local/bin/7za Parent: bash [1316]

Version: ??? (???)

PID: 1319 Thread: Unknown

Link (dyld) error:

lazy pointer not found

comment:6 Changed 15 years ago by toby@…

I can't look into an issue that I can't reproduce....

comment:7 Changed 15 years ago by pjenvey@…

Someone reported this same error message with textproc/highlight, see bug 6095

The solution was to force compiling with gcc 3

Funny thing is, I wasn't able to reproduce this p7zip problem either with both with both gcc 3.3 and gcc 4.0 (OS X 10.4.3)

Changed 15 years ago by josh_root@…

Attachment: Portfile.patch added

suggested fix

comment:8 Changed 15 years ago by josh_root@…

Cc: josh_root@… added

My patch is doing what the readme says to do BTW -- the default makefile.machine is configured for Linux. Compiling with the -s option ("Remove all symbol table and relocation information from the executable") seems like something that could easily confuse the dynamic linker.

comment:9 Changed 15 years ago by narf_tm@…

Thank you. Your patch fixes the problem for me. Any chance this patch will make it into the port?

comment:10 Changed 15 years ago by josh_root@…

Could the original reporter reopen this bug, please? It may get attention sooner if it shows up on the list of unresolved bugs.

comment:11 Changed 15 years ago by toby@…

Resolution: worksforme
Status: closedreopened

comment:12 Changed 15 years ago by toby@…

Still can't reproduce this, but I'll take a look at the patch.

comment:13 Changed 15 years ago by toby@…

Resolution: fixed
Status: reopenedclosed

committed a portable version of the fix

Note: See TracTickets for help on using tickets.