#57237 closed defect (fixed)

Configuring rb-rcairo fails (on Mojave)

Reported by: jpmelko Owned by: kimuraw (kimura wataru)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: rb-rcairo

Description

Installing rb-poppler from scratch give thefollowing error:

port -N -p install rb-poppler
.... many lines
--->  Fetching distfiles for rb-rcairo
--->  Attempting to fetch rcairo-1.14.3.tar.gz from http://lil.fr.distfiles.macports.org/ruby
--->  Verifying checksums for rb-rcairo
--->  Extracting rb-rcairo
--->  Configuring rb-rcairo
Error: Failed to configure rb-rcairo: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_ruby_rb-rcairo/rb-rcairo/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port rb-poppler failed
--->  Updating database of binaries
--->  Scanning binaries for linking errors
--->  No broken files found.
--->  No broken ports found.
--->  Some of the ports you installed have notes:
  libpsl has the following notes:
libpsl API documentation is provided by the port 'libpsl-docs'.

Attachments (1)

main.log (12.3 KB) - added by jpmelko 23 months ago.

Download all attachments as: .zip

Change History (8)

Changed 23 months ago by jpmelko

Attachment: main.log added

comment:1 Changed 23 months ago by jmroot (Joshua Root)

Cc: kimuraw removed
Owner: set to kimuraw
Port: rb-rcairo added
Status: newassigned
Summary: Configuring rb-cairo fails (on Mojave)Configuring rb-rcairo fails (on Mojave)

comment:2 Changed 22 months ago by kimuraw (kimura wataru)

I cannot reproduce your problem on my Mojave Mac.

your error log says "xproto.pc" not found. please show me results of the following two commands.

  1. port contents xorg-xorgproto | grep xproto.pc
  2. pkg-config --debug --exists xproto

results on my Mac:

# [1]
$ port contents xorg-xorgproto | grep xproto.pc
  /opt/local/share/pkgconfig/dmxproto.pc
  /opt/local/share/pkgconfig/xproto.pc

# [2]
$ pkg-config --debug --exists xproto                      
Error printing disabled by default due to use of output options --exists, --atleast/exact/max-version, --list-all or no output option at all. Value of --print-errors: 0
Error printing disabled
Adding virtual 'pkg-config' package to list of known packages
Looking for package 'xproto'
Looking for package 'xproto-uninstalled'
Reading 'xproto' from file '/opt/local/share/pkgconfig/xproto.pc'
Parsing package file '/opt/local/share/pkgconfig/xproto.pc'
  line>prefix=/opt/local
 Variable declaration, 'prefix' has value '/opt/local'
  line>exec_prefix=${prefix}
 Variable declaration, 'exec_prefix' has value '/opt/local'
  line>libdir=${exec_prefix}/lib
 Variable declaration, 'libdir' has value '/opt/local/lib'
  line>includedir=${prefix}/include
 Variable declaration, 'includedir' has value '/opt/local/include'
  line>includex11dir=${prefix}/include/X11
 Variable declaration, 'includex11dir' has value '/opt/local/include/X11'
  line> 
  line>Name: Xproto
  line>Description: Xproto headers
  line>Version: 7.0.32
  line>Cflags: -I${includedir}
Path position of 'xproto' is 2
Adding 'xproto' to list of known packages

comment:3 Changed 22 months ago by jpmelko

There is an error before at aline 98: Could not create Makefile

Here are the results of your commands

titi@Bacchus: Downloads $ port contents xorg-xorgproto | grep xproto.pc
  /opt/local/share/pkgconfig/dmxproto.pc
  /opt/local/share/pkgconfig/xproto.pc
titi@Bacchus: Downloads $ pkg-config --debug --exists xproto 
Error printing disabled by default due to use of output options --exists, --atleast/exact/max-version, --list-all or no output option at all. Value of --print-errors: 0
Error printing disabled
Adding virtual 'pkg-config' package to list of known packages
Looking for package 'xproto'
Looking for package 'xproto-uninstalled'
Reading 'xproto' from file '/opt/local/share/pkgconfig/xproto.pc'
Parsing package file '/opt/local/share/pkgconfig/xproto.pc'
  line>prefix=/opt/local
 Variable declaration, 'prefix' has value '/opt/local'
  line>exec_prefix=${prefix}
 Variable declaration, 'exec_prefix' has value '/opt/local'
  line>libdir=${exec_prefix}/lib
 Variable declaration, 'libdir' has value '/opt/local/lib'
  line>includedir=${prefix}/include
 Variable declaration, 'includedir' has value '/opt/local/include'
  line>includex11dir=${prefix}/include/X11
 Variable declaration, 'includex11dir' has value '/opt/local/include/X11'
  line> 
  line>Name: Xproto
  line>Description: Xproto headers
  line>Version: 7.0.32
  line>Cflags: -I${includedir}
Path position of 'xproto' is 2
Adding 'xproto' to list of known packages


comment:4 Changed 22 months ago by kimuraw (kimura wataru)

In 6cf3dda10a2afbd7f8bc8b3137c840bd460eb4aa/macports-ports (master):

ruby/rb-rcairo: fix possible build failure

add PKG_CONFIG_PATH to avoild error from missing xproto.pc at configure.
see #57237

comment:5 Changed 22 months ago by kimuraw (kimura wataru)

Thanks jpmelko,

I added PKG_CONFIG_PATH into rb-rcairo to solve your error. Try sudo port selfupdate && sudo port install rb-rcairo.

comment:6 Changed 22 months ago by jpmelko

It works now

Thanks

comment:7 Changed 22 months ago by kimuraw (kimura wataru)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.