Opened 2 years ago

Closed 2 years ago

#57264 closed defect (duplicate)

mysql57 @5.7.17 Build failure on macOS Mojave (10.14)

Reported by: emiel (Emiel van de Laar) Owned by: pixilla (Bradley Giesbrecht)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: mysql57

Description

Recently switch to macOS Mojave and am unable to build the mysql57 port. Appears to be related to boost

Build log is attached.

In addition I have the boost @1.66.0_3 port installed as well. However, the build log is showing it is picking up the included boost 1.59.0 version.

boost @1.66.0_3

--

$ sudo port clean --all mysql57 mysql57-server
--->  Cleaning mysql57
--->  Cleaning mysql57-server

$ sudo port build mysql57
--->  Computing dependencies for mysql57
--->  Fetching distfiles for mysql57
--->  Attempting to fetch mysql-5.7.17.tar.gz from http://mirror.leaseweb.com/mysql/Downloads/MySQL-5.7
--->  Attempting to fetch mysql-5.7.17.tar.gz from http://mysql.mirror.kangaroot.net/Downloads/MySQL-5.7
--->  Attempting to fetch mysql-5.7.17.tar.gz from https://distfiles.macports.org/mysql57
--->  Attempting to fetch boost_1_59_0.tar.gz from https://distfiles.macports.org/mysql57
--->  Verifying checksums for mysql57                                                
--->  Extracting mysql57
--->  Applying patches to mysql57
--->  Configuring mysql57
--->  Building mysql57
Error: Failed to build mysql57: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql57/mysql57/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port mysql57 failed

Attachments (1)

main.log.gz (171.8 KB) - added by emiel (Emiel van de Laar) 2 years ago.
Build log

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by emiel (Emiel van de Laar)

Attachment: main.log.gz added

Build log

comment:1 Changed 2 years ago by emiel (Emiel van de Laar)

Looking into this further it appears to be a duplicate of #56228.

Last edited 2 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Owner: set to pixilla
Status: newassigned

comment:3 Changed 2 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.