Opened 7 months ago

Closed 3 months ago

#57341 closed defect (duplicate)

opencv @3.4.1_2 +contrib error - build failure

Reported by: lbarrows Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: opencv

Description (last modified by mf2k (Frank Schima))

Installing opencv 3.4.1_2 with the following invocation fails under High Sierra.

sudo /opt/local/bin/port install opencv@3.4.1_2+contrib

Cleaning the port does not bring it back to a functioning state. Changing into the build tree and attempting to build the software after a build failure leads to the following errors extracted from the full output, which may indicate a possible protobuf update without testing the opencv +contribs build:


In file included from 
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:12:2: error: 
      This file was generated by a newer version of protoc which is
#error This file was generated by a newer version of protoc which is

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:13:2: error: 
      incompatible with your Protocol Buffer headers. Please update
#error incompatible with your Protocol Buffer headers.  Please update

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.1/modules/dnn/misc/caffe/opencv-caffe.pb.h:23:10: fatal error: 
      'google/protobuf/arena.h' file not found
#include <google/protobuf/arena.h>

I've attached the /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_opencv/opencv/main.log file as referenced in the port build error message. Let me know if there is any other information required.

Lester Barrows

Attachments (1)

main.log (793.9 KB) - added by lbarrows 7 months ago.
main.log from the failed OpenCV +contrib build

Download all attachments as: .zip

Change History (7)

Changed 7 months ago by lbarrows

Attachment: main.log added

main.log from the failed OpenCV +contrib build

comment:1 Changed 7 months ago by kencu (Ken)

probably the same error as the caffe build, which doesn't build against protobuf3 due to needing c++11.

One quick & easy test is to try building it with clang-7.0; if that fixes it, then we know it's a c++11 thing.

comment:2 Changed 7 months ago by kencu (Ken)

nope. Installing protobuf3-cpp didn't work, nor did then building it against clang-7.0.

comment:3 Changed 7 months ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: OpenCV contriub protobuf build breaks broken High Sierra removed

In the future, please use WikiFormatting.

comment:4 Changed 6 months ago by lbarrows

I have confirmed that the OpenCV +contrib build is still broken under High Sierra two weeks later, using either protobuf-cpp or protobuf3-cpp.

comment:5 Changed 5 months ago by kencu (Ken)

comment:6 Changed 3 months ago by jmroot (Joshua Root)

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.