Opened 2 years ago

Closed 6 months ago

#57382 closed defect (fixed)

graphviz-gui: destroot fails with Xcode 10

Reported by: billgertz (Bill Gertz) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: mojave Cc: szhorvat (Szabolcs Horvát)
Port: graphviz-gui graphviz-gui-devel

Description

The package graphviz-gui fails to install at Staging to destroot. The error messages in full are, with log message before hand for context:

:info:destroot     cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/graphviz-2.40.1/macosx
:info:destroot     /bin/mkdir -p /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/destroot/Applications/MacPorts/Graphviz.app/Contents/Resources
:info:destroot ** INSTALL FAILED **
:info:destroot The following build commands failed:
:info:destroot 	SymLink /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/graphviz-2.40.1/macosx/build/Release/Graphviz.app /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/destroot/Applications/MacPorts/Graphviz.app



:info:destroot (1 failure)
:info:destroot Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/graphviz-2.40.1/macosx" && /usr/bin/xcodebuild  -alltargets -configuration Release install INSTALL_PATH=/Applications/MacPorts  OBJROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/graphviz-2.40.1/macosx/build/" SYMROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/graphviz-2.40.1/macosx/build/" MACOSX_DEPLOYMENT_TARGET=10.14 ARCHS=x86_64 SDKROOT="/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++" PREFIX=/opt/local DSTROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/destroot"

:info:destroot Exit code: 65
:error:destroot Failed to destroot graphviz-gui: command execution failed
:debug:destroot Error code: NONE
:debug:destroot Backtrace: command execution failed
:debug:destroot     while executing
:debug:destroot "$procedure $targetname"

Not really an expert with MacPorts - anyone else with this problem?

Attachments (1)

main.log (447.4 KB) - added by billgertz (Bill Gertz) 2 years ago.
Error log file from graphviz-gui build

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by billgertz (Bill Gertz)

Attachment: main.log added

Error log file from graphviz-gui build

comment:1 Changed 2 years ago by billgertz (Bill Gertz)

Checking both the source and target directories of the Symlink and they both seem to be there, after the command executes:

sapphire:~ root# ls -la /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/destroot/Applications/MacPorts/
total 0
drwxr-xr-x  3 root  admin  96 Oct 14 12:24 .
drwxr-xr-x  3 root  admin  96 Oct 14 12:24 ..
drwxr-xr-x  3 root  admin  96 Oct 14 12:24 Graphviz.app

sapphire:~ root# ls -la /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz-gui/work/destroot/Applications/MacPorts/Graphviz.app/Contents/
total 0
drwxr-xr-x  4 root  admin  128 Oct 14 12:24 .
drwxr-xr-x  3 root  admin   96 Oct 14 12:24 ..
drwxr-xr-x  2 root  admin   64 Oct 14 12:24 MacOS
drwxr-xr-x  2 root  admin   64 Oct 14 12:24 Resources

Not sure how the Symlink failed by succeeding...

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Status: newassigned

I assume this is a duplicate of #57137.

comment:3 Changed 2 years ago by ddrum2000

I think it is a duplicate of #57137 as I submitted it a few weeks ago right after Mojave was released.

comment:4 Changed 2 years ago by szhorvat (Szabolcs Horvát)

Cc: szhorvat added

comment:5 Changed 6 months ago by ryandesign (Ryan Schmidt)

Port: graphviz-gui-devel added
Resolution: fixed
Status: assignedclosed
Summary: graphviz-gui package fails destroortgraphviz-gui: destroot fails with Xcode 10

A workaround was applied to graphviz in [27eaaca5341ce9bd4cbb08a1d111f67239ec1a7c/macports-ports] and graphviz-devel in [3beb9ee18999473766fbe77378105e44e6a919b9/macports-ports] but I still believe it should be worked around centrally in the xcode portgroup as mentioned long ago in #57137.

Note: See TracTickets for help on using tickets.