Opened 7 months ago

Closed 7 months ago

#57533 closed enhancement (fixed)

curl: fbopenssl is unnecessary

Reported by: sharris40 (Spencer Harris) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: curl

Description

curl hasn't used fbopenssl for anything since 7.38. The only references to it in the source code are in some old Netware build files. Removing it would solve #51362 and #51363.

Change History (2)

comment:1 in reply to:  description Changed 7 months ago by ryandesign (Ryan Schmidt)

Status: assignedaccepted

Replying to sharris40:

curl hasn't used fbopenssl for anything since 7.38.

Thanks for finding this. Confirmed: use of fbopenssl was removed in https://github.com/curl/curl/commit/9ad282b1ae1135e7d5dd2e466ff8671c1e4ee04b.

comment:2 Changed 7 months ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: acceptedclosed

In fc7dcaca5cebf97886a4fb15ea4069fe787f67ae/macports-ports (master):

curl: Remove spnego variant which did nothing

Closes: #57533
Closes: #51363
Closes: #51362

Note: See TracTickets for help on using tickets.