Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#57541 closed defect (duplicate)

gts @0.7.6-20121130_0 +universal build fails

Reported by: mopihopi Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ryandesign (Ryan Schmidt), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: gts

Description

Upgrading gts @0.7.6 +universal to @0.7.6-20121130_0 +universal fails, on macOS 10.12.6 16G1510 with Xcode 9.2 9C40b.

$ port installed gts and active
The following ports are currently installed:
  gts @0.7.6_3+universal (active)
$ sudo port upgrade gts
--->  Computing dependencies for gts
--->  Fetching archive for gts
--->  Attempting to fetch gts-0.7.6-20121130_0+universal.darwin_16.i386-x86_64.tbz2 from https://packages.macports.org/gts
--->  Attempting to fetch gts-0.7.6-20121130_0+universal.darwin_16.i386-x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/gts
--->  Attempting to fetch gts-0.7.6-20121130_0+universal.darwin_16.i386-x86_64.tbz2 from http://kmq.jp.packages.macports.org/gts
--->  Fetching distfiles for gts
--->  Verifying checksums for gts
--->  Extracting gts
--->  Configuring gts
--->  Building gts
Error: Failed to build gts: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_gts/gts/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Attachments (1)

gts-main.log (167.2 KB) - added by mopihopi 17 months ago.
gts build log

Download all attachments as: .zip

Change History (4)

Changed 17 months ago by mopihopi

Attachment: gts-main.log added

gts build log

comment:1 Changed 17 months ago by kencu (Ken)

996     :info:build libtool: link: /usr/bin/clang -dynamiclib -Wl,-flat_namespace -Wl,-undefined -Wl,suppress -o .libs/libgts-0.7.5.dylib  .libs/object.o .libs/point.o .libs/vertex.o .libs/segment.o .libs/edge.o .libs/triangle.o .libs/face.o .libs/kdtree.o .libs/bbtree.o .libs/misc.o .libs/predicates.o .libs/heap.o .libs/eheap.o .libs/fifo.o .libs/matrix.o .libs/surface.o .libs/stripe.o .libs/vopt.o .libs/refine.o .libs/iso.o .libs/isotetra.o .libs/split.o .libs/psurface.o .libs/hsurface.o .libs/cdt.o .libs/boolean.o .libs/named.o .libs/oocs.o .libs/container.o .libs/graph.o .libs/pgraph.o .libs/partition.o .libs/curvature.o .libs/tribox3.o   -lm -L/opt/local/lib -lglib-2.0 -lintl  -Os -arch i386 -Wl,-headerpad_max_install_names -arch i386 -Wl,-framework -Wl,CoreFoundation   -install_name  /opt/local/lib/libgts-0.7.5.dylib -compatibility_version 6 -current_version 6.1 -Wl,-single_module
997	:info:build ld: warning: text-based stub file /System/Library/Frameworks//AudioToolbox.framework/Versions/A/AudioToolbox.tbd and library file /System/Library/Frameworks//AudioToolbox.framework/Versions/A/AudioToolbox are out of sync. Falling back to library file for linking.
998	:info:build ld: warning: text-based stub file /System/Library/Frameworks//QuartzCore.framework/Versions/A/QuartzCore.tbd and library file /System/Library/Frameworks//QuartzCore.framework/Versions/A/QuartzCore are out of sync. Falling back to library file for linking.
999	:info:build ld: in '/opt/local/lib/libxar.1.dylib', file was built for x86_64 which is not the architecture being linked (i386): /opt/local/lib/libxar.1.dylib for architecture i386
1000	:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
1001	:info:build make[3]: *** [libgts.la] Error 1

It looks like it wants xar installed as universal. Do you have xar installed as universal?

comment:2 Changed 17 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

gts does not use xar. You've encountered a linker bug. Either deactivate xar, or install xar universal, prior to installing gts universal.

Duplicate of #36438. See also comment:ticket:52337:9.

comment:3 Changed 17 months ago by mopihopi

Thanks. Deactivating xar temporarily broke llvm, but allowed gts to be upgraded, and reactivating xar afterwards fixed llvm.

Note: See TracTickets for help on using tickets.