Opened 2 years ago

Closed 2 years ago

#57553 closed defect (duplicate)

Failed to configure gmp

Reported by: jatishpatel Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: gmp

Description (last modified by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez))

Apologies in advance, I am a beginner. I am trying to install SUMO and I received the below error:

Error: Failed to configure gmp, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.1.2/config.log
Error: Failed to configure gmp: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port sumo failed

I assumed that this had something to do with gmp. I tried to clean and then install gmp and received the following error:

--->  Fetching distfiles for gmp
--->  Verifying checksums for gmp
--->  Extracting gmp
--->  Applying patches to gmp
--->  Configuring gmp
Error: Failed to configure gmp, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.1.2/config.log
Error: Failed to configure gmp: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gmp failed

Can anybody provide some advice on next steps. If more information is required, please let me know.

Attachments (2)

config.log (10.2 KB) - added by jatishpatel 2 years ago.
main.log (9.1 KB) - added by jatishpatel 2 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Description: modified (diff)
Owner: set to MarcusCalhoun-Lopez
Port: gmp added
Status: newaccepted

Greetings and welcome.

For future reference, bug reports will likely be more successful if you follow the guide, such as

  • Use WikiFormatting
  • Filling in the Port box
  • Entering the email of the maintainer

For now, however, we need more information to diagnose the problem. Please run

  • sudo port clean gmp
  • sudo port selfupdate
  • sudo port install gmp

If there is still a failure, attach

  • /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/main.log
  • /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.1.2/config.log

Changed 2 years ago by jatishpatel

Attachment: config.log added

Changed 2 years ago by jatishpatel

Attachment: main.log added

comment:2 Changed 2 years ago by jatishpatel

Marcus,

I appreciate the advice and for your patience. I've run through the above 3 steps and I am still getting an error. Attached are the requested log files.

Jatish

comment:3 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

This error seems to be

xcrun: error: unable to exec Xcode native xcrun (Permission denied).

This has happened a couple of time before (#41138 and #48776).
Previously, it was fixed by

xcode-select --reset

Afterwards, please run

sudo port clean gmp
sudo port install gmp

If this works, please let us know in this ticket.

comment:4 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: duplicate
Status: acceptedclosed

Marking this as a duplicate of #48776.

Note: See TracTickets for help on using tickets.