Opened 3 weeks ago

Last modified 15 hours ago

#57641 assigned defect

inkscape @0.92.3_5+quartz: renders black on Mojave

Reported by: hmeine (Hans Meine) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: inkscape

Description

After migration to Mojave (MacPorts reinstall), I was trying to install inkscape +quartz from scratch. I used the following command to check that I installed all dependencies which support +quartz also with that variant active:

# port installed rdepof:inkscape and variant:quartz
The following ports are currently installed:
  cairo @1.14.12_0+quartz+x11 (active)
  cairomm @1.12.2_0+quartz+x11 (active)
  glib2 @2.58.1_0+quartz (active)
  glib2 @2.58.1_0+x11
  glibmm @2.56.0_1+quartz (active)
  gtk2 @2.24.32_0+quartz (active)
  gtk2 @2.24.32_0+x11
  gtkmm @2.24.5_1+quartz (active)
  gtkspell2 @2.0.16_7+quartz (active)
  librsvg @2.42.2_2
  librsvg @2.42.2_2+quartz (active)
  pango @1.42.4_0+quartz+x11 (active)
  pangomm @2.40.1_0+quartz+x11 (active)

Problems:

  1. When I start inkscape (which works for me, contrary to the report in #57604), I only get a black rendering (no visible document outline or graphical elements on it).
  2. Furthermore, other necessary redraw or resize events do not seem to be invoked / handled; for instance, the main window contains the whole GUI cramped into a small upper left subpart of the full window, until it is resized.
  3. I tried to open an existing file, and also had to manually trigger redraws of the file dialog by resizing, in order to get the file listing filled, for instance.

I then tried port install inkscape for the +x11 variant, but apparently that did not have a big effect; the dependencies (which I am partly also using for the Gimp) are still installed with +quartz, and the problems retain.

Change History (5)

comment:1 Changed 3 weeks ago by jmroot (Joshua Root)

Owner: set to dbevans
Port: inkscape added
Status: newassigned

comment:2 Changed 5 days ago by rubendibattista (Ruben Di Battista)

I also confirm the same behaviour. Inkscape (+quartz) starts ( I can see the original starting UI) but then keep the CPU at 100% and I cannot resize the window. Moreover I tried to download and run the App from the inkscape website that runs correctly on Mojave (and moreover is better looking graphically).

comment:3 Changed 3 days ago by rubendibattista (Ruben Di Battista)

I tried to edit the Portfile to compile with cmake and I'm at least getting this warning that could be related:

2018-12-09 04:33:15.986 inkscape[20995:3162070] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
Last edited 3 days ago by rubendibattista (Ruben Di Battista) (previous) (diff)

comment:4 Changed 3 days ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:5 Changed 15 hours ago by thede (Thede Loder)

I performed a build using +quartz, and get the same results as hmeine. One of the errors reported on the console was failed connections to dbus. A manual install of dbus, plus manual activation of dbus via launchd for org.freedesktop.dbus-session made that error go away, but did not solve the UI window draw/refresh issue, and the CPU remains pegged at 100% on a core. Other tidbits: the application cannot be closed via a Quit from the main OSX menu. Selecting Quit from the file menu from the floating main window works.

Note: See TracTickets for help on using tickets.