Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#57664 closed defect (duplicate)

py27-glewpy @0.7.4_11: Cannot convert 'src.glew.GLbyte *' to Python object

Reported by: atalkingegg Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-glewpy

Description (last modified by Schamschula (Marius Schamschula))

Here's the lines from the log where it goes off

:info:build /usr/bin/clang -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch x86_64 -I/opt/local/include -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c src/glew.c -o build/temp.macosx-10.13-x86_64-2.7/src/glew.o
:info:build src/glew.c:1:2: error: Do not use this file, it is the result of a failed Pyrex compilation.
:info:build #error Do not use this file, it is the result of a failed Pyrex compilation.
:info:build  ^
:info:build 1 error generated.
:info:build error: command '/usr/bin/clang' failed with exit status 1
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-glewpy/py27-glewpy/work/glewpy-0.7.4" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg build 
:info:build Exit code: 1
:error:build Failed to build py27-glewpy: command execution failed

Attachments (1)

main.log (59.9 KB) - added by atalkingegg 2 years ago.
complete port install log

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by atalkingegg

Attachment: main.log added

complete port install log

comment:1 Changed 2 years ago by Schamschula (Marius Schamschula)

Description: modified (diff)
Keywords: py27-glewpy removed

Please use wiki markup!

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: py27-glewpy on MacOSX 10.13.6 Xcode 9.1.4 fails to buildpy27-glewpy @0.7.4_11: Cannot convert 'src.glew.GLbyte *' to Python object

Duplicate of #48285.

comment:3 Changed 2 years ago by mf2k (Frank Schima)

Port: py-glewpy added; py27-glewpy removed
Note: See TracTickets for help on using tickets.