Opened 4 years ago

Closed 4 years ago

#57814 closed defect (worksforme)

installing grep aborts with error code 71

Reported by: lemzwerg (Werner Lemberg) Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: grep

Description

[macports-ports d3b59876b6dde9a4a26135a9c6b59320080eb23f] [macOS 10.7.5 11G63] [Xcode 4.6.3 4H1503]

Installing grep fails:

> sudo port install grep
--->  Computing dependencies for grep
--->  Fetching distfiles for grep
--->  Verifying checksums for grep
--->  Extracting grep
--->  Configuring grep
Error: Failed to configure grep:
  configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_macports_macports- ports_sysutils_grep/grep/main.log
  for details.

Log file attached.

Attachments (1)

main.log (15.5 KB) - added by lemzwerg (Werner Lemberg) 4 years ago.
Main.log file of failing grep installation.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by lemzwerg (Werner Lemberg)

Attachment: main.log added

Main.log file of failing grep installation.

comment:1 Changed 4 years ago by kencu (Ken)

thanks. A puzzle at this moment as grep recently built on every buildbot <http://packages.macports.org/grep/>, so it's something unique. I see you're on 10.7 setup to libc++. Should still be fine. Will check.

comment:2 Changed 4 years ago by kencu (Ken)

Owner: set to Schamschula
Port: grep added
Status: newassigned

comment:3 Changed 4 years ago by kencu (Ken)

you appear to be running MacPorts base development version. The configure phase ends with a file not found error, and your path seems short on entries : PATH='/usr/bin:/Users/Lemberg/This'

can you post up your .profile?

cd ~
cat .profile

thanks

comment:4 Changed 4 years ago by raimue (Rainer Müller)

MacPorts overrides the PATH completely for compilation phases. The problem was probably introduced when configuring this custom MacPorts installation. Also check binpath in ${prefix}/etc/macports/macports.conf.

Note the guide also covers this: https://guide.macports.org/#installing.macports.source.multiple

comment:5 Changed 4 years ago by lemzwerg (Werner Lemberg)

Here's my .profile file:

export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
export PATH="/usr/local/texlive/2018/bin/x86_64-darwinlegacy:$PATH"

export PS1='\u:\w> '
export LESS="-M -I -R"
export EDITOR=joe

and my macports.conf file (beautified to avoid long lines). Note that directory This is a test mentioned in binpath doesn't exist.

prefix                  /opt/local
portdbpath              /opt/local/var/macports
binpath                 /Users/Lemberg/This is a Test\
                        :/usr/local/texlive/2018/bin/x86_64-darwinlegacy\
                        :/opt/local/bin\
                        :/opt/local/sbin\
                        :/bin\
                        :/sbin\
                        :/usr/bin\
                        :/usr/sbin
applications_dir        /Applications/MacPorts
frameworks_dir          /opt/local/Library/Frameworks
sources_conf            /opt/local/etc/macports/sources.conf
variants_conf           /opt/local/etc/macports/variants.conf
cxx_stdlib              libc++
buildfromsource         always
universal_archs         x86_64 i386

Up to now I was able to install all Macports packages; this is the first problem ever encountered.

comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt)

Evidently, spaces are not supported in binpath. Rename your "This is a Test" directory so that its name does not contain spaces, update binpath in macports.conf with the new name, and try again.

comment:7 Changed 4 years ago by lemzwerg (Werner Lemberg)

Worked, thanks. It's quite interesting that this port fails with my old binpath, while hundreds of other port updates didn't have a single problem – I had added this directory for testing purposes two months ago, and all updates since then worked flawlessly.

comment:8 Changed 4 years ago by Schamschula (Marius Schamschula)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.