Opened 15 years ago

Closed 15 years ago

#5782 closed defect (fixed)

NEW: mail/gnupg2

Reported by: pkern@… Owned by: pkern@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: yeled@…
Port:

Description

This is the 1.9.x development branch which will later become gnupg2. It is ALPHA and should be considered as such. gnupg and gnupg2 should be installed at the same time, the binary is called `gpg2'. This release features utilities like gpg-agent, S/MIME and smartcard support.

Attachments (4)

Portfile (1.5 KB) - added by pkern@… 15 years ago.
mail/gnupg2/Portfile
patch-pthlibs (1.0 KB) - added by pkern@… 15 years ago.
mail/gnupg2/files/patch-pthlibs
Portfile.2 (1.6 KB) - added by pkern@… 15 years ago.
mail/gnupg2/Portfile
Portfile.3 (1.6 KB) - added by pkern@… 15 years ago.
mail/gnupg2/Portfile

Download all attachments as: .zip

Change History (16)

comment:1 Changed 15 years ago by pkern@…

dependson: 4292

devel/libksba needs to be updated to 0.9.12 first.

comment:2 Changed 15 years ago by pkern@…

Cc: yeled@… added
dependson: 42924294

Changed 15 years ago by pkern@…

Attachment: Portfile added

mail/gnupg2/Portfile

Changed 15 years ago by pkern@…

Attachment: patch-pthlibs added

mail/gnupg2/files/patch-pthlibs

comment:3 Changed 15 years ago by yeled@…

(In reply to comment #0)

This is the 1.9.x development branch which will later become gnupg2. It is ALPHA and should be considered as such. gnupg and gnupg2 should be installed at the same time,

should we make it a depends_lib ?

comment:4 Changed 15 years ago by yeled@…

Warning: Target configure has an undeclared dependency on bison Warning: Target configure has an undeclared dependency on libgcrypt Warning: Target configure has an undeclared dependency on libgpg-error

comment:5 Changed 15 years ago by yeled@…

also, the ${prefix}/bin/gpg-agent is used by both gnupg and gnupg2 ..

are you shure we should have both, and not just symlink gpg2 to gpg?

comment:6 Changed 15 years ago by pkern@…

(In reply to comment #5)

Warning: Target configure has an undeclared dependency on bison Warning: Target configure has an undeclared dependency on libgcrypt Warning: Target configure has an undeclared dependency on libgpg-error

libgcrypt and libgpg-error are right in any case. I thought I tracked it down correctly, I at least hadn't got those warnings and I initially copied the Portfile of gnupg. Anyway, I'll upload a fixed Portfile.

(In reply to comment #6)

also, the ${prefix}/bin/gpg-agent is used by both gnupg and gnupg2 ..

No, gnupg did not install it here. If it does in a variant, then please remove it from there. The new gpg- agent is more sophisticated.

are you shure we should have both, and not just symlink gpg2 to gpg?

Yes. gpg2 is not mature for use with OpenPGP, and it is advised to continue with gpg for that (if you do not depend on smartcard usage etc.).

comment:7 Changed 15 years ago by pkern@…

(In reply to comment #4)

(In reply to comment #0)

This is the 1.9.x development branch which will later become gnupg2. It is ALPHA and should be considered as such. gnupg and gnupg2 should be installed at the same time,

should we make it a depends_lib ?

That should have been a "could", I am sorry.

Changed 15 years ago by pkern@…

Attachment: Portfile.2 added

mail/gnupg2/Portfile

comment:8 Changed 15 years ago by pkern@…

attachments.isobsolete: 01

comment:9 Changed 15 years ago by yeled@…

(In reply to comment #7)

(In reply to comment #6)

also, the ${prefix}/bin/gpg-agent is used by both gnupg and gnupg2 ..

No, gnupg did not install it here. If it does in a variant, then please remove it from there. The new

gpg-

agent is more sophisticated.

Sorry! the new portfile should also conflict with gpg-agent, not gnupg.

/opt/local/bin/gpg-agent is provided by: gpg-agent

comment:10 Changed 15 years ago by pkern@…

(In reply to comment #10)

Sorry! the new portfile should also conflict with gpg-agent, not gnupg.

Hm. If the separate gpg-agent Portfile is really needed I would rather not build it in gnupg2. Apart of the version difference (gpg-agent 1.9.10 vs. gnugp2 1.9.19) they build from the same sources anyway.

Changed 15 years ago by pkern@…

Attachment: Portfile.3 added

mail/gnupg2/Portfile

comment:11 Changed 15 years ago by pkern@…

attachments.isobsolete: 01

comment:12 Changed 15 years ago by yeled@…

Resolution: fixed
Status: newclosed

(In reply to comment #12)

Created an attachment (id=4762) [edit] mail/gnupg2/Portfile

This Portfile removes gpg-agent from the build, it has its separate port.

this is great.

12:18 backspace:dports/mail/gnupg2% port contents Port gnupg2 contains:

/opt/local/bin/gpg-connect-agent /opt/local/bin/gpg2 /opt/local/bin/gpgconf /opt/local/bin/gpgkey2ssh /opt/local/bin/gpgsm /opt/local/bin/gpgsm-gencert.sh /opt/local/bin/gpgv2 /opt/local/bin/kbxutil /opt/local/bin/scdaemon /opt/local/bin/watchgnupg /opt/local/lib/gnupg/pcsc-wrapper /opt/local/sbin/addgnupghome /opt/local/share/gnupg/gpg-conf.skel /opt/local/share/info/gnupg.info /opt/local/share/locale/de/LC_MESSAGES/gnupg2.mo

I'll commit it now.

Note: See TracTickets for help on using tickets.