Opened 4 months ago

Closed 4 months ago

#57836 closed defect (duplicate)

selfupdate shows no error on unclean git sources

Reported by: ascheman (Gerd Aschemann) Owned by:
Priority: Normal Milestone:
Component: base Version:
Keywords: Cc:
Port:

Description

I receive MacPorts sources via git (Repo in /opt/local/var/macports/sources/github.com/macports/macports-ports). For some reason my repo was unclean (files marked for deletion, as I could see by manually running git status), eg.

...
On branch master
Your branch is up to date with 'origin/master'.

Changes to be committed:
  (use "git reset HEAD <file>..." to unstage)

        deleted:    java/BrowserLauncher2/Portfile
        deleted:    java/BrowserLauncher2/files/browserlaunchertestapp.patch
        deleted:    java/BrowserLauncher2/files/patch-source-at-jta-Regor.java.diff
        deleted:    java/android/Portfile

However, sudo port selfupdate returned very fast and showed no error:

--->  Updating MacPorts base sources using rsync
MacPorts base version 2.5.4 installed,
MacPorts base version 2.5.4 downloaded.
--->  Updating the ports tree

Only my subsequent sudo port -bcp upgrade outdated showed a warning

Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'.
Nothing to upgrade.

AND there still was a lot to upgrade as I found out when cleaning up the git repo!

Change History (3)

comment:1 Changed 4 months ago by jmroot (Joshua Root)

Component: portsbase

Is the error shown if you sync rather than selfupdate?

comment:2 Changed 4 months ago by jmroot (Joshua Root)

Ping?

comment:3 Changed 4 months ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

No reply from the reporter, so I will assume this is a duplicate of #56549. Feel free to reopen if there is evidence to the contrary.

Note: See TracTickets for help on using tickets.