Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#57913 closed defect (duplicate)

OpenBLAS @0.3.5 failed build

Reported by: datajerk Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: OpenBLAS

Description

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_OpenBLAS/OpenBLAS/work/.tmp/cckEC5U9.s:2260:no such instruction: `vmovss %xmm0, (%rdx,%rax,4)'
:info:build make[2]: *** [sbdsvdx.o] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_OpenBLAS/OpenBLAS/work/OpenBLAS-0.3.5/lapack-netlib/SRC'
:info:build make[1]: *** [lapacklib] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_OpenBLAS/OpenBLAS/work/OpenBLAS-0.3.5/lapack-netlib'
:info:build make: *** [netlib] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_OpenBLAS/OpenBLAS/work/OpenBLAS-0.3.5'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_math_OpenBLAS/OpenBLAS/work/OpenBLAS-0.3.5" && /usr/bin/make -j20 -w all AR=/usr/bin/ar RANLIB=/usr/bin/ranlib 
:info:build Exit code: 2

Attachments (1)

main.log (2.6 MB) - added by datajerk 7 months ago.
main.log

Change History (5)

Changed 7 months ago by datajerk

Attachment: main.log added

main.log

comment:1 Changed 7 months ago by datajerk

MacOS 10.14.2 Xcode: 10.1

comment:2 Changed 7 months ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Different OS version, but looks like essentially the same issue as #57912.

comment:3 Changed 7 months ago by michaelld (Michael Dickens)

I'm guessing the issue is that OpenBLAS failed to properly detect CPU features, and enabled AVX512 even though it's not actually available. You can get an idea of what OSX thinks the processor's capabilities are via a command such as sysctl -A | grep -i avx .

Sometimes the "devel" port will work, since it contains fixes since the latest release. Thus, can you try installing the "openblas-devel" port and see if that works?

comment:4 Changed 7 months ago by datajerk

"devel" port, same issue

Note: See TracTickets for help on using tickets.