Opened 7 months ago

Last modified 4 months ago

#57931 assigned defect

emacs-app-devel @20190111_0: menu bar requires 2 clicks, is unresponsive, or has delays

Reported by: iqgrande Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: upstream Cc:
Port: emacs-app-devel

Description

Greetings:

I am using port "emacs-app-devel" while awaiting upstream changes to "emacs-app" to enable better usage on macOS Mojave (see #57217). Anyways, when I launch /Applications/MacPorts/Emacs.app, click on the main window, and then click on "Buffers" on the menu bar, it doesn't display. Subsequent clicks will typically display it. During normal work, it seems as if activating the menu items requires 2 clicks for all of the pull-down menus to activate. I also attached a video showing this.

Methodology

I removed ~/.emacs.d and tested this with no Emacs configurations present.

System Information

$ port version
Version: 2.5.4
$ xcodebuild -version
Xcode 10.1
Build version 10B61
$ port installed | grep emacs-app-devel
  emacs-app-devel @20190111_0 (active)

I hope this helps. I am not sure if this is an issue with upstream Emacs or how it is built.

Kind regards, Anthony

Attachments (1)

emacs-app-devel_clicking.mov (2.3 MB) - added by iqgrande 7 months ago.
This is a video of me clicking pull-down menus and them not displaying properly.

Change History (9)

Changed 7 months ago by iqgrande

This is a video of me clicking pull-down menus and them not displaying properly.

comment:1 Changed 7 months ago by iqgrande

It is worth noting that I am new to macOS Mojave and I don't recall this behavior being present. Anyways, other Emacs installations I have (e.g., 26.1) exhibit this same behavior.

comment:2 Changed 7 months ago by cjones051073 (Chris Jones)

Thanks. This I believe is an upstream bug, so can I urge you to follow the guidelines at

https://debbugs.gnu.org/Emacs.html

to report the issue there.

comment:3 Changed 7 months ago by mf2k (Frank Schima)

Milestone: MacPorts 2.6.0

The Milestone field is for use by Macports team members only, please do not set it.

comment:4 Changed 7 months ago by mf2k (Frank Schima)

Keywords: upstream added

comment:5 Changed 7 months ago by iqgrande

I tried submitting a ticket however I don't see it yet on their mailing list. I will check back and, when I find it, will update with a URL.

comment:6 Changed 7 months ago by iqgrande

The URL I am checking for the time being (until I get an automated response) is here.

comment:7 Changed 7 months ago by iqgrande

The open bug with Emacs is here.

comment:8 Changed 4 months ago by ra1nb0w

Can you test the last -devel?

Note: See TracTickets for help on using tickets.