Opened 4 years ago

Closed 4 years ago

#57939 closed defect (invalid)

at-spi2-core build fails under Mojave 10.14.2 : "Otool does not work"

Reported by: JVD66 (Jason Vas Dias) Owned by: dbevans (David B. Evans)
Priority: Not set Milestone:
Component: ports Version:
Keywords: Cc:
Port: at-spi2-core

Description (last modified by kencu (Ken))

A port install of 'libvirt' and 'virt-manager':

$ port -sv install libvirt virt-manager

(I have Qemu installed) failed building the 'at-spi2-core' dependency with:

[49/53] Generating symbol file 'atspi/f291f98@@atspi@sha/libatspi.0.dylib.symbols'.
FAILED: atspi/f291f98@@atspi@sha/libatspi.0.dylib.symbols 
/opt/local/Library/Frameworks/Python.framework/Versions/3.7/bin/meson --internal symbolextractor atspi/libatspi.0.dylib 'atspi/f291f98@@atspi@sha/libatspi.0.dylib.symbols' 
Traceback (most recent call last):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/bin/meson", line 11, in <module>
    load_entry_point('meson==0.49.0', 'console_scripts', 'meson')()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/mesonbuild/mesonmain.py", line 192, in main
    return run(sys.argv[1:], launcher)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/mesonbuild/mesonmain.py", line 181, in run
    return run_script_command(args[1], args[2:])
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/mesonbuild/mesonmain.py", line 145, in run_script_command
    return module.run(script_args)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/mesonbuild/scripts/symbolextractor.py", line 111, in run
    gen_symbols(libfile, outfile, options.cross_host)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/mesonbuild/scripts/symbolextractor.py", line 100, in gen_symbols
    osx_syms(libfilename, outfilename)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/mesonbuild/scripts/symbolextractor.py", line 77, in osx_syms
    raise RuntimeError('Otool does not work.')
RuntimeError: Otool does not work.
[50/53] Generating Atspi-2.0.gir with a custom command.
FAILED: atspi/Atspi-2.0.gir 

Otool is provided by cctools . I am not sure exactly what it is meant to do (no Otools man-page is installed!) but apparently meson is not happy with however it is or is not doing it.

I guess one MUST use virtualbox on Mac OS X because Qemu is so limited and libvirt + virt-manager do not build?

Change History (6)

comment:1 Changed 4 years ago by kencu (Ken)

Description: modified (diff)
Owner: set to dbevans
Port: at-spi2-core added
Status: newassigned

comment:2 Changed 4 years ago by kencu (Ken)

libvirt and at-spi2-core do build on Mojave:

http://packages.macports.org/libvirt/libvirt-4.10.0_0+gnutls.darwin_18.x86_64.tbz2
http://packages.macports.org/at-spi2-core/at-spi2-core-2.28.0_0.darwin_18.x86_64.tbz2

There's no package for virt-manager -- so not positive about that one just now. Probably a license thing.

So it appears to be something different on your system that could be sorted out.

To get you going, though, any idea why you're struggling to build it from source port -s instead of just installing the pre-built binary from the buildbot?

comment:3 Changed 4 years ago by Schamschula (Marius Schamschula)

otool (note the command is lower case) comes with the cctools port, but Xcode CLI also provides /usr/bin/otool.

I have at-spi2-core installed on several Mojave machines.

comment:4 Changed 4 years ago by JVD66 (Jason Vas Dias)

Oops, this was because I had an experimental build of GNU Binutils (containing objdump) in my $PATH . Reading more about llvm-otool once I located the documentation for it. Sorry! Closing as not a bug.

comment:5 Changed 4 years ago by JVD66 (Jason Vas Dias)

Priority: NormalNot set
Type: defectrequest

comment:6 Changed 4 years ago by kencu (Ken)

Resolution: invalid
Status: assignedclosed
Type: requestdefect
Note: See TracTickets for help on using tickets.