Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#58024 closed defect (fixed)

fribidi 1.0.5 fails to build +universal

Reported by: JohnFHall (John Hall) Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: JohnFHall (John Hall), mopihopi
Port: fribidi

Description (last modified by kencu (Ken))

:info:build   CCLD     gen-unicode-version
**:info:build ld: warning: The i386 architecture is deprecated for macOS (remove from the Xcode build setting: ARCHS)**
:info:build ld: warning: ignoring file gen-unicode-version.o, file was built for x86_64 which is not the architecture being linked (i386): gen-unicode-version.o
:info:build Undefined symbols for architecture i386:
:info:build   "_main", referenced from:
:info:build      implicit entry/start for main executable
:info:build ld: symbol(s) not found for architecture i386
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[2]: *** [gen-unicode-version] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_fribidi/fribidi/work/fribidi-1.0.5/gen.tab'
:info:build make[1]: *** [fribidi-unicode-version.h] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_fribidi/fribidi/work/fribidi-1.0.5/lib'
:info:build make: *** [lib/fribidi-unicode-version.h] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_fribidi/fribidi/work/fribidi-1.0.5'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_fribidi/fribidi/work/fribidi-1.0.5" && /usr/bin/make -w all 
:info:build Exit code: 2
:error:build Failed to build fribidi: command execution failed
:debug:build Error code: CHILDSTATUS 25947 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_fribidi/fribidi/main.log for details.

Attachments (4)

main.log (27.7 KB) - added by JohnFHall (John Hall) 21 months ago.
fribidi build log
main-universal (27.7 KB) - added by JohnFHall (John Hall) 21 months ago.
fribidi: $sudo port -v install fribidi -universal
fribidi-installed.rtf (17.4 KB) - added by JohnFHall (John Hall) 21 months ago.
fribidi dependents, rdeps and user installed ports
main.2.log (22.8 KB) - added by Seraphyyy 21 months ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 21 months ago by JohnFHall (John Hall)

Cc: JohnFHall added

comment:2 Changed 21 months ago by kencu (Ken)

Description: modified (diff)

comment:3 Changed 21 months ago by kencu (Ken)

Hi John. Please do this:

sudo port clean fribidi
sudo port -v install fribidi

and if it fails again, please post up the main.log so we can see what happened. To post up the main log for fribidi if it fails, do this:

cp /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_fribidi/fribidi/main.log ~/main.log

and then attach it to this ticket with the attachments -> attach file button..

Changed 21 months ago by JohnFHall (John Hall)

Attachment: main.log added

fribidi build log

comment:4 Changed 21 months ago by kencu (Ken)

looks like there is some kind of issue building it +universal. You might be the first person who has tried that.

Any idea why it's trying to build it +universal? If you don't need it that way, perhaps building it just normally would be more satisfactory.

Or force it to be non-universal with

sudo port clean fribidi
sudo port -v install fribidi -universal

Changed 21 months ago by JohnFHall (John Hall)

Attachment: main-universal added

fribidi: $sudo port -v install fribidi -universal

comment:5 Changed 21 months ago by JohnFHall (John Hall)

No idea why universal. But still fails with -universal.

Changed 21 months ago by JohnFHall (John Hall)

Attachment: fribidi-installed.rtf added

fribidi dependents, rdeps and user installed ports

comment:6 Changed 21 months ago by JohnFHall (John Hall)

If it helps, I attach a result file of:- sudo port dependents fribidi sudo port rdeps fribidi sudo port installed

Note: fribidi @1.0.5_0 is shown as active.

If all this is unecessary, forgive me, I don't know much about macports, other than running its useful utilities!!

comment:7 Changed 21 months ago by kencu (Ken)

Owner: set to neverpanic
Status: newassigned
Summary: fribidi 1.0.5 fails to buildfribidi 1.0.5 fails to build +universal

comment:8 Changed 21 months ago by kencu (Ken)

Confirmed -- the +universal build of fribidi is broken. Adding PortGroup muniversal 1.0 does not fix it, unfortunately.

For John -- you have a great many ports installed as +universal -- this is likely to be frustrating for you in the longer term, as you have to build everything yourself (ugh) and some ports don't build +universal, as you can see.

I'm not sure how it came to pass that you have so many +universal ports -- I presume you didn't do that on purpose. But getting rid of the "+universal virus" as we sometimes call it can be tedious.

I would be tempted to start going through your installed ports, activating non-universal variants and uninstalling the +universal ones, and cancel out any rev-upgrades until you're all finished. If you can get rid of every +universal variant, your life will be happier.

comment:9 Changed 21 months ago by Seraphyyy

While porting "wine", it fails to build fribidi. How can I avoid this error? It looks like fetching +universal...

--->  Fetching archive for fribidi

--->  Attempting to fetch fribidi-1.0.5_0+universal.darwin_16.i386-x86_64.tbz2 from http://kmq.jp.packages.macports.org/fribidi
--->  Attempting to fetch fribidi-1.0.5_0+universal.darwin_16.i386-x86_64.tbz2 from https://packages.macports.org/fribidi
--->  Attempting to fetch fribidi-1.0.5_0+universal.darwin_16.i386-x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/fribidi
--->  Fetching distfiles for fribidi
--->  Verifying checksums for fribidi
--->  Extracting fribidi
--->  Configuring fribidi
--->  Building fribidi
Error: Failed to build fribidi: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_fribidi/fribidi/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port wine failed

Changed 21 months ago by Seraphyyy

Attachment: main.2.log added

comment:10 Changed 21 months ago by kencu (Ken)

Same error. At present, fribidi does not build +universal. It was just updated, and this needs to be sorted out.

comment:11 in reply to:  8 Changed 21 months ago by JohnFHall (John Hall)

Replying to kencu:

Confirmed -- the +universal build of fribidi is broken. Adding PortGroup muniversal 1.0 does not fix it, unfortunately.

For John -- you have a great many ports installed as +universal -- this is likely to be frustrating for you in the longer term, as you have to build everything yourself (ugh) and some ports don't build +universal, as you can see.

I'm not sure how it came to pass that you have so many +universal ports -- I presume you didn't do that on purpose. But getting rid of the "+universal virus" as we sometimes call it can be tedious.

The suggestion to remove universal was going well, until I got to wine (or wine-devel). Even though I tried -univeral to the build, as well as having -universal in /opt/local/etc/macport/variant.conf, wine stubbonly build with +universal, and rebulds its dependent with +universal, undoing most of the work I had done. Bugger! I've opened a ticket #58025 for wine, but I'm not hopeful of action.

At least I know where all the +universal builds came from.

Thank you for your help. John Hall

Last edited 21 months ago by JohnFHall (John Hall) (previous) (diff)

comment:12 Changed 21 months ago by kencu (Ken)

yes, presently wine needs universal. OK, two hard positions then.

wine needs universal, and fribidi won't build that way at present.

comment:13 Changed 21 months ago by jmroot (Joshua Root)

The build system builds silently by default which means the actual commands being run aren't logged. I've disabled this in [bed1a1f789eb33b571de54f0bf265e49d1ae3816/macports-ports]; please generate a new log after syncing up with this change.

comment:14 Changed 21 months ago by jmroot (Joshua Root)

Looks like gen.tab/Makefile.am is overriding our supplied CFLAGS.

comment:15 in reply to:  14 Changed 21 months ago by kencu (Ken)

Replying to jmroot:

Looks like gen.tab/Makefile.am is overriding our supplied CFLAGS.

Yep that was it. Changing this in the referenced file:

- CFLAGS = $(CFLAGS_FOR_BUILD)
+ CFLAGS += $(CFLAGS_FOR_BUILD)

fixes the universal build.

$ port -v installed fribidi
The following ports are currently installed:
  fribidi @1.0.5_0+universal (active) platform='darwin 10' archs='i386 x86_64' date='2019-02-06T15:41:15-0800'

I'll push up the patch.

comment:17 Changed 21 months ago by mopihopi

Cc: mopihopi added

comment:18 Changed 21 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

In f66a78e62dfc636044b5c796cbab65b435ff7552/macports-ports (master):

fribidi: fix universal/non-default-arch built

Closes: #58024
Closes: https://github.com/macports/macports-ports/pull/3594

comment:19 Changed 21 months ago by JohnFHall (John Hall)

Thank all. Works for me +universal. Now to get the wine guy to allow -universal...

John

Note: See TracTickets for help on using tickets.