Opened 13 days ago

Last modified 7 days ago

#58027 assigned defect

Kile is not opening on Mojave

Reported by: bodait Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: kde4-kile

Description (last modified by mf2k (Frank Schima))

Hi, I have recently upgraded to OSX Mojave. When i tried to use macports i was prompted to reinstall it. I followed the instructions on wiki:Migration but not all ports have been reinstalled from my myports.txt, and i experienced a flickering of the Kile editor. So i removed macports completely following https://guide.macports.org/chunked/installing.macports.uninstalling.html Then i reinstalled macports for mojave, and on this clean install i installed only kde4-kile (and it's dependencies). I don't think there was an error during this installation. Then i started dbus as well as kbuildsycoca4. I tried to launch Kile by clicking on it's icon in Launchpad but Kile wouldn't start up; the icon is bouncing on the tray for a few seconds and then disappears. I'm aware of the tickets #39164 and #36644 but starting dbus doesn't seem to be the problem. I note that every time i installed kile, an OSX crash report came up saying that kbuildsycoca4 stopped running. I'm not sure that it is actually running once i start it from Terminal. I don't have a deep knowledge of computers.

Change History (5)

comment:1 Changed 13 days ago by mf2k (Frank Schima)

In the future, please fill in the Port field.

Last edited 13 days ago by mf2k (Frank Schima) (previous) (diff)

comment:2 Changed 13 days ago by mf2k (Frank Schima)

Cc: NicosPavlov removed
Keywords: kile doesn't start kbuildsycoca4 removed
Owner: set to NicosPavlov
Port: kde4-kile added
Status: newassigned

comment:3 Changed 13 days ago by mf2k (Frank Schima)

Description: modified (diff)

comment:4 Changed 7 days ago by bodait

This morning OSX was offering an update to install. Upon completing that, which required a system restart, Kile opened up when i initiated that. However, the above mentioned flickering does persist. It makes work impossible, without exaggeration. I suppose this latter is a completely independent issue. Shall i create a new ticket for that?

comment:5 Changed 7 days ago by bodait

Regarding the flickering, the issue was solved for me by following the instructions that I received earlier upon installing kde4-kile. The instruction/note did actually belong to qt4-mac:

Users experiencing graphics glitches on newer OS versions (10.13 and up) can

experiment with different graphics drawing systems that can be set in the Interface tab of the /Applications/MacPorts/Qt4/qtconfig.app utility. Raster mode is the preferred mode but is not compatible with all non-standard widget styles. Keep an eye on the Fonts setting before saving!

Note: See TracTickets for help on using tickets.