#58039 closed defect (duplicate)

librsvg-2.44.11_0 fails to build in macOS 10.14.3

Reported by: mcmara (Jack McMara) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: librsvg

Description

The port:

imac-gm1 [code]$ sudo port clean librsvg
--->  Cleaning librsvg
imac-gm1 [code]$ sudo port install librsvg
--->  Computing dependencies for librsvg
--->  Fetching archive for librsvg
--->  Attempting to fetch librsvg-2.44.11_0+quartz.darwin_18.x86_64.tbz2 from https://packages.macports.org/librsvg
--->  Attempting to fetch librsvg-2.44.11_0+quartz.darwin_18.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/librsvg
--->  Attempting to fetch librsvg-2.44.11_0+quartz.darwin_18.x86_64.tbz2 from http://jnb.za.packages.macports.org/packages/librsvg
--->  Fetching distfiles for librsvg
--->  Verifying checksums for librsvg
--->  Extracting librsvg
--->  Applying patches to librsvg
--->  Configuring librsvg
Error: Failed to configure librsvg, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.11/config.log
Error: Failed to configure librsvg: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port librsvg failed

The system:

imac-gm1 [code]$ uname -a
Darwin wvrtc-imac-gm1.local 18.2.0 Darwin Kernel Version 18.2.0: Thu Dec 20 20:46:53 PST 2018; root:xnu-4903.241.1~1/RELEASE_X86_64 x86_64
(reverse-i-search)`xcodeb': ^Codebuild -scheme ark-analysis-restore-edu build

The compiler:

imac-gm1 [code]$ gcc -v
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/include/c++/4.2.1
Apple LLVM version 10.0.0 (clang-1000.11.45.5)
Target: x86_64-apple-darwin18.2.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

Attachments (2)

config.log (57.0 KB) - added by mcmara (Jack McMara) 21 months ago.
main.log (144.5 KB) - added by mcmara (Jack McMara) 21 months ago.

Download all attachments as: .zip

Change History (4)

Changed 21 months ago by mcmara (Jack McMara)

Attachment: config.log added

Changed 21 months ago by mcmara (Jack McMara)

Attachment: main.log added

comment:1 Changed 21 months ago by mf2k (Frank Schima)

Keywords: librsvg 10.14.3 mojave removed
Owner: set to dbevans
Port: librsvg added; librsvg-2.44.11_0 removed
Status: newassigned

In the future, please add the port maintainer(s) to Cc (port info --maintainers librsvg), if any.

comment:2 Changed 21 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #57955. You need to rebuild gawk.

Note: See TracTickets for help on using tickets.