Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#58081 closed defect (fixed)

mysql @ 5.7.25_0: Failed to build mysql57: command execution failed

Reported by: dgelmer Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: mysql57

Description

  macOS 10.13.6 (17G5019)
  XCode 10.1
  Model Identifier:	iMac11,1
  Processor Name:	Intel Core i7
  Processor Speed:	2.8 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	8 MB
  Memory:	12 GB
  Boot ROM Version:	60.0.0.0.0

Attachments (1)

main.log.gz (152.7 KB) - added by dgelmer 20 months ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql57/mysql57/main.log

Download all attachments as: .zip

Change History (7)

Changed 20 months ago by dgelmer

Attachment: main.log.gz added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql57/mysql57/main.log

comment:1 Changed 20 months ago by mf2k (Frank Schima)

Keywords: highsierra x86_64 removed

comment:2 Changed 20 months ago by enekochan (enekochan)

I was having the same issue. As seen in #56228 the problem is that MySQL 5.7 can only use boost 1.59.0 and I had 1.66.0 installed (by another port). Removing boost and then installing MySQL 5.7 again solved the problem:

$ sudo port uninstall boost
$ sudo port clean mysql57
$ sudo port install mysql57

comment:3 Changed 20 months ago by Schamschula (Marius Schamschula)

Strange. When I updated the Portfile, I cleanly built mysql57 5.7.25 with boost 1.66.0 installed and active.

It should suffice to deactivate boost, rather than uninstalling it.

comment:4 Changed 20 months ago by Schamschula (Marius Schamschula)

A second thought:

Perhaps, in my case, building in trace mode prevented the boost issue, as mysql builds against its own version of boost, whereas the boost package is hidden.

comment:5 Changed 20 months ago by Schamschula (Marius Schamschula)

Owner: set to Schamschula
Resolution: fixed
Status: newclosed

In c4245ca8b9d3e84e0316007407362cb5a958ec23/macports-ports (master):

mysql57: use conflicts_build for boost build issue

Closes: #58081

comment:6 Changed 20 months ago by TheLastLovemark

How do I use conflicts_build ??

Note: See TracTickets for help on using tickets.