#58120 closed update (fixed)

libpsl: move build dependencies to python3

Reported by: dmarteau (David Marteau) Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: libpsl

Description

As we are close to python2 EOL, it should be time to consider to moving build dependencies from python2 to python3.

Change History (3)

comment:1 Changed 19 months ago by mf2k (Frank Schima)

Does upstream support python 3.7?

comment:2 Changed 19 months ago by dmarteau (David Marteau)

The README file says that "You should have python2.7+ installed.", which include python3.x

From the release notes:

09.11.2017 Release V0.19.0
...
* psl_make_dafsa now works with python2 and python3
...
Last edited 19 months ago by dmarteau (David Marteau) (previous) (diff)

comment:3 Changed 18 months ago by mf2k (Frank Schima)

Owner: set to mf2k
Resolution: fixed
Status: newclosed

In dfb3e5740dac867e67db94e6e1d6d1a3a9911d67/macports-ports (master):

libpsl: Update to version 0.21.0

  • Switch to python37

Closes: #58120

Note: See TracTickets for help on using tickets.