Opened 2 years ago

Closed 17 months ago

#58142 closed defect (fixed)

cmake @3.12.3_0+universal configure failure with Xcode 10 on 10.13

Reported by: nikgervae Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: cmake

Description (last modified by ryandesign (Ryan Schmidt))

Per the transcript below, when I try to install youtube-dl, at the point where "Configuring cmake" appears, a panel appears onscreen telling me I need to install Java for the java command-line tool. I have done this, and the error continues to appear. If I enter the command "which java", it replies: "/usr/bin/java", so it appears to be installed.

% sudo port install youtube-dl
--->  Computing dependencies for youtube-dl
--->  Cleaning youtube-dl
--->  Scanning binaries for linking errors
--->  Found 2 broken files, matching files to ports      
--->  Found 1 broken port, determining rebuild order
You can always run 'port rev-upgrade' again to fix errors.
The following ports will be rebuilt: physfs @3.0.1+universal
Continue? [Y/n]: 
--->  Computing dependencies for cmake
--->  Configuring cmake
Error: Failed to configure cmake: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/main.log for details.
Error: Problem while installing cmake
Error: rev-upgrade failed: Error rebuilding physfs
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Attachments (1)

main.log (1.2 MB) - added by nikgervae 2 years ago.
cmake main.log file from failed build

Download all attachments as: .zip

Change History (8)

comment:1 Changed 2 years ago by nikgervae

Summary: Trying to install youtube-dl raises an alert panel saying I need to install Java, which I have doneTrying to install youtube-dl raises an alert panel saying I need to install Java (which I have done), then fails

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: youtube-dl java removed
Milestone: MacPorts 2.6.0
Owner: set to michaelld
Port: cmake added
Status: newassigned
Summary: Trying to install youtube-dl raises an alert panel saying I need to install Java (which I have done), then failscmake: Alert panel appears saying I need to install Java (which I have done), then fails

Your transcript shows that youtube-dl had already been successfully installed prior to you running sudo port install youtube-dl this time. It also shows that for some reason physfs is considered broken, and rebuilding it required cmake, which was unable to be configured for some reason.

/usr/bin/java is part of macOS and is always there, even if Java is not installed. If Java is installed, /usr/bin/java runs it; if not, it displays the dialog box you encountered.

Please attach the main.log file mentioned in the transcript so that we can see what the problem was. I don't think cmake requires Java (it didn't used to), so it might be something else.

Changed 2 years ago by nikgervae

Attachment: main.log added

cmake main.log file from failed build

comment:3 Changed 2 years ago by nikgervae

FWIW, I get the same problem trying to install something fresh (port_cutleaves).

I had tried to update youtube-dl, got the failure described, and then I thought I had uninstalled it before trying to install "fresh", but of course none of the dependencies had been removed. This is why I was trying to install port_cutleaves.

comment:4 Changed 2 years ago by jmroot (Joshua Root)

Summary: cmake: Alert panel appears saying I need to install Java (which I have done), then failscmake @3.12.3_0+universal configure failure with Xcode 10 on 10.13
:info:configure -- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -- broken
:info:configure CMake Error at Modules/CMakeTestCCompiler.cmake:52 (message):
:info:configure   The C compiler
:info:configure     "/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang"
:info:configure   is not able to compile a simple test program.
:info:configure   It fails with the following output:
:info:configure     Change Dir: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.12.3-i386/CMakeFiles/CMakeTmp
:info:configure     
:info:configure     Run Build Command:"/usr/bin/make" "cmTC_ba13e/fast"
:info:configure     make -f CMakeFiles/cmTC_ba13e.dir/build.make CMakeFiles/cmTC_ba13e.dir/build
:info:configure     Building C object CMakeFiles/cmTC_ba13e.dir/testCCompiler.c.o
:info:configure     /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang   -pipe -Os -arch i386  -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk -mmacosx-version-min=10.13   -o CMakeFiles/cmTC_ba13e.dir/testCCompiler.c.o   -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.12.3-i386/CMakeFiles/CMakeTmp/testCCompiler.c
:info:configure     Linking C executable cmTC_ba13e
:info:configure     /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.12.3-i386/Bootstrap.cmk/cmake -E cmake_link_script CMakeFiles/cmTC_ba13e.dir/link.txt --verbose=1
:info:configure     /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -pipe -Os -arch i386  -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk -mmacosx-version-min=10.13 -Wl,-search_paths_first -Wl,-headerpad_max_install_names -L/opt/local/lib -Wl,-headerpad_max_install_names -arch i386  CMakeFiles/cmTC_ba13e.dir/testCCompiler.c.o  -o cmTC_ba13e 
:info:configure     ld: warning: The i386 architecture is deprecated for macOS (remove from the Xcode build setting: ARCHS)
:info:configure     ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/lib/libSystem.tbd, missing required architecture i386 in file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/lib/libSystem.tbd
:info:configure     ld: dynamic main executables must link with libSystem.dylib for architecture i386
:info:configure     clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:configure     make[1]: *** [cmTC_ba13e] Error 1
:info:configure     make: *** [cmTC_ba13e/fast] Error 2

Apparently one of cmake's configure checks is deciding to use the 10.14 SDK, even though you're on 10.13 and building for i386, which the 10.14 SDK doesn't support.

comment:5 Changed 2 years ago by nikgervae

Well, I may have jumped the gun for solving the cmake problem, but I uninstalled youtube-dl and confirmed this time, then installed it fresh. I now have youtube-dl installed and running properly.

comment:6 Changed 17 months ago by ryandesign (Ryan Schmidt)

Has duplicate #59341.

comment:7 Changed 17 months ago by kencu (Ken)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.