#58262 closed defect (fixed)

asymptote @2.48: needs a newer compiler on 10.8 and older

Reported by: mojca (Mojca Miklavec) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: mamoll (Mark Moll)
Port: asymptote glm

Description (last modified by mojca (Mojca Miklavec))

See the logs:

In file included from drawpath3.cc:11:
In file included from /opt/local/include/glm/glm.hpp:105:
In file included from /opt/local/include/glm/detail/setup.hpp:33:
/opt/local/include/glm/detail/../simd/platform.h:133:5: error: "GLM requires Clang 3.4 / Apple Clang 6.0 or higher"
#                       error "GLM requires Clang 3.4 / Apple Clang 6.0 or higher"
                        ^
/opt/local/include/glm/detail/../simd/platform.h:214:3: error: "GLM_COMPILER undefined, your compiler may not be supported by GLM. Add #define GLM_COMPILER 0 to ignore this message."
#       error "GLM_COMPILER undefined, your compiler may not be supported by GLM. Add #define GLM_COMPILER 0 to ignore this message."
        ^

It would be really nice if dependencies could blacklist compilers separately for their own use and separately for software needing them. Then any port using that dependency would not attempt to use the ancient compiler / there would be no need to blacklist compiler in a recursive way to each and every user of a dependency.

Change History (2)

comment:1 Changed 20 months ago by mojca (Mojca Miklavec)

Cc: mamoll added
Description: modified (diff)
Port: glm added

comment:2 Changed 11 months ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: assignedclosed

This issue was fixed after we switch to libc++ on 10.8.

Note: See TracTickets for help on using tickets.