#58310 closed defect (worksforme)

proxychains-ng 4.14 breaks nmap functionality

Reported by: JohnFHall (John Hall) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: ra1nb0w
Port: proxychains-ng

Description (last modified by mf2k (Frank Schima))

Prior to the upgrade I was successfully opening tor, then running:-

sudo proxychains4 nmap -A -Pn xx.xx.xx.xx

Now that command errors with:-

[proxychains] config file found: /opt/local/etc/proxychains.conf
[proxychains] preloading /opt/local/lib/libproxychains4.dylib
[proxychains] DLL init: proxychains-ng 4.14
Starting Nmap 7.70 ( https://nmap.org ) at 2019-04-06 11:08 AEDT
**Assertion failed: (rc == 0), function collect_dnet_interfaces, file netutil.cc, line 1379.
Abort trap: 6**

Change History (15)

comment:1 Changed 16 months ago by JohnFHall (John Hall)

Description: modified (diff)

comment:2 Changed 16 months ago by mf2k (Frank Schima)

In the future, please use WikiFormatting.

comment:3 Changed 16 months ago by mf2k (Frank Schima)

Description: modified (diff)
Port: @4.14_0 removed

comment:4 Changed 16 months ago by jmroot (Joshua Root)

Cc: ra1nb0w pmetzger added

comment:6 Changed 16 months ago by JohnFHall (John Hall)

Ahh. Yes. If I comment proxy_dns line in proxychains.conf all is well.

comment:7 Changed 16 months ago by jmroot (Joshua Root)

So is this invalid? Or a bug in nmap?

comment:8 Changed 16 months ago by pmetzger (Perry E. Metzger)

I have nothing to do with the maintenance of this package...

comment:9 Changed 16 months ago by pmetzger (Perry E. Metzger)

Cc: pmetzger removed

comment:10 in reply to:  7 Changed 16 months ago by ra1nb0w

Replying to jmroot:

So is this invalid? Or a bug in nmap?

seems mutal as stated by rofl0r (proxychains-ng developer) but nobody contacted nmap to arise the problem. JohnFHall have you the time to report the problem to dev@…?

comment:11 Changed 16 months ago by JohnFHall (John Hall)

As the OP I realise that the bug I highlighted was indeed caused by the update to proxychains, but what I had forgotten was that I had previously (originally) commented out the proxy_dns entry, and I expect that the update re-wrote the proxychain.conf file, removing my edit.

As roflOr is aware of the interworking problem due to nmap not handling proxychains proxy_dns, and the nmap publisher has their own provision for socks 4 usage, I don't think much would be gained by contacting dev@….

If any one else feels differently, please feel free to do so.

My vote is to close this case... as I made a mistake !!

comment:12 Changed 16 months ago by ra1nb0w

Seems reasonable to close. Just to ask: why are you using proxychains nmap [options] and avoiding nmap --proxy [ip:port]?

comment:13 Changed 16 months ago by JohnFHall (John Hall)

I was hoping no one would ask... I only came across tor/proxychains literally weeks ago from an article online. I'm old, but it seemed like a good idea to mask my ip when scanning malicious agents who are scanning my ip.

I was not aware of the nmap --proxy [ip:port] way of doing the same thing.

comment:14 Changed 16 months ago by ra1nb0w

Ok. the ticket can be closed by admins (I believe)

comment:15 Changed 16 months ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.