Opened 19 months ago

Last modified 16 months ago

#58325 assigned defect

X11 is misbehaving: time lag in "command display"

Reported by: vdoublie Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: chrstphrchvz (Christopher Chavez)
Port: xorg-libX11

Description (last modified by mf2k (Frank Schima))

Once X11 is started (by the way Xquartz is behaving the same) the xterm window starts try and type... no "type" shows and then there is a time loag between the rentern command and the execution. after a while it seems it catches up for execution time but still NO "typesetting" on the xterm command line

there is no obvious "error" message however using the log console: on the computer console:

error	11:13:33.359163 +0200	kernel	Sandbox: xterm(32024) System Policy: deny(1) file-write-create /System/Library/Fonts/.uuid.TMP-i0UT9M
default	11:15:51.603265 +0200	X11.bin	xterm: fatal IO error 35 (Resource temporarily unavailable) or KillClient on X server "/private/tmp/com.apple.launchd.tTwoBh2iLI/org.macports:0"

and on the system logs:

Apr 11 10:33:08 jarvis X11.bin[30482]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Apr 11 10:37:34 jarvis org.macosforge.xquartz.privileged_startx[30755]: Removing stale /opt/X11/var/run/font_cache.lock
Apr 11 10:37:34 jarvis org.macosforge.xquartz.X11.stub[30795]: launchd check-in failed: No such process
Apr 11 10:37:35 jarvis X11.bin[30726]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Apr 11 10:45:35 jarvis org.macosforge.xquartz.privileged_startx[31077]: Removing stale /opt/X11/var/run/font_cache.lock
Apr 11 10:45:36 jarvis org.macosforge.xquartz.X11.stub[31217]: launchd check-in failed: No such process
Apr 11 10:45:36 jarvis X11.bin[31048]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Apr 11 11:11:17 jarvis X11.bin[31788]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Apr 11 11:19:25 jarvis X11.bin[32305]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Apr 11 11:22:37 jarvis X11.bin[32546]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug

Change History (8)

comment:1 Changed 19 months ago by vdoublie

Port: xorg-libX11 added
Version: 2.5.4

comment:2 Changed 19 months ago by vdoublie

By the way: when xorg-server was updated to v1.20.4, the behaviour of the xterm remain unchanged and good. the problem occurred right after the xerm update to v344

comment:3 Changed 19 months ago by mf2k (Frank Schima)

Priority: HighNormal

The Priority field is for use by Macports team members only, please do not set it.

comment:4 Changed 19 months ago by mf2k (Frank Schima)

In the future, please use WikiFormatting and add the port maintainer(s) to Cc (port info --maintainers xorg-libX11), if any.

comment:5 Changed 19 months ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: set to jeremyhu
Status: newassigned

comment:6 Changed 18 months ago by chrstphrchvz (Christopher Chavez)

Should this ticket's port field be set to (or include) xterm?

Could this be related to the double-buffer issue that was recently discussed on the macports-users and addressed inxterm @344_1 (f23d0689b8)?

comment:7 Changed 18 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:8 Changed 16 months ago by vdoublie

could it be something related to fonts compatibility. setting fonts to defaults seems to do the trick.

Note: See TracTickets for help on using tickets.