Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#58371 closed defect (fixed)

dvisvgm @2.7_1: Checksum mismatch for dvisvgm-2.7.tar.gz

Reported by: rjs110112 Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: chrstphrchvz (Christopher Chavez)
Port: texlive

Description (last modified by jmroot (Joshua Root))

The input is: sudo port install dvisvgm. And I get the output:

--->  Computing dependencies for dvisvgm
--->  Verifying checksums for dvisvgm
Error: Checksum (rmd160) mismatch for dvisvgm-2.7.tar.gz
Error: Checksum (sha256) mismatch for dvisvgm-2.7.tar.gz
Error: Checksum (size) mismatch for dvisvgm-2.7.tar.gz
Error: Failed to checksum dvisvgm: Unable to verify file checksums
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_dvisvgm/dvisvgm/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port dvisvgm failed

I think this is a problem since the texlive can't be properly installed.

Attachments (1)

main.log (968.4 KB) - added by rjs110112 18 months ago.

Download all attachments as: .zip

Change History (10)

Changed 18 months ago by rjs110112

Attachment: main.log added

comment:1 Changed 18 months ago by rjs110112

I've fixed it by downloading the dvisvgm package from http://macports.distfiles.ionic.de/dvisvgm/ and put it in the directory "/opt/local/var/macports/distfiles/dvisvgm" by hand. (this replaces the existing file which is smaller in size) I made a duplication of the package with long name which also pre-exists in the directory. I don't know if that matters. Anyway, then sudo port install dvisvgm would work. I can install texlive now.

comment:2 Changed 18 months ago by chrstphrchvz (Christopher Chavez)

This ticket should be filed specifically against the dvisvgm port and owner set to its maintainer (michaelld).

I can reproduce the checksum mismatch issue.

comment:3 Changed 18 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:4 Changed 18 months ago by chrstphrchvz (Christopher Chavez)

The checksum in the portfile matches the releases download, not the tarball download.

The most recent change to the dvisvgm portfile ([bf528304dd/macports-ports]) commented out this line:

github.tarball_from releases

This caused the default tarball download to be used, which has different checksums; but the checksums were not updated by that commit, nor was the revision incremented.

Was switching this port to tarball intended, or should this be reverted to using releases? (If the latter, I would think the incrementing the revision would not be necessary.)

comment:5 Changed 18 months ago by chrstphrchvz (Christopher Chavez)

I have opened a pull request to attempt to fix this: https://github.com/macports/macports-ports/pull/4127

comment:6 Changed 18 months ago by michaelld (Michael Dickens)

Thanks for alerting me to this issue, and that you for the PR moving back from github tags to release. My preference when possible is to allow the local system to do the work, so keeping things as tags and treating this like a stealth update: tweaking the dist subdir & fixing the checksums & other dependencies. Doing this moves the autoconf stuff to the main part of the Portfile that's shared by both ports, which simplifies everything. I'll push this fix shortly, for this ticket & the other you opened for the devel version.

comment:7 Changed 18 months ago by michaelld (Michael Dickens)

Owner: set to michaelld
Resolution: fixed
Status: newclosed

In 333402990a85709ede23229fada3fe1c9067beeb/macports-ports (master):

dvisvgm: fix release checksums and devel dependencies overwrite; rev bump both

Closes: #58371
Closes: #58373

comment:8 Changed 18 months ago by jmroot (Joshua Root)

Description: modified (diff)

comment:9 Changed 18 months ago by mf2k (Frank Schima)

Priority: HighNormal
Note: See TracTickets for help on using tickets.