#58643 closed defect (fixed)

youtube-dl @2019.06.08: Unable to download from youtube. Signature extraction failed

Reported by: DougReider (Doug Reider) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: youtube-dl

Description

This has been corrected on ​https://yt-dl.org https://github.com/ytdl-org/youtube-dl/issues/21520

$ youtube-dl "https://www.youtube.com/watch?v=S3VMfzoBO7Y"
[youtube] S3VMfzoBO7Y: Downloading webpage
[youtube] S3VMfzoBO7Y: Downloading video info webpage
[youtube] S3VMfzoBO7Y: Downloading js player vflIucxJp
ERROR: Signature extraction failed: Traceback (most recent call last):
  File "/opt/local/bin/youtube-dl/youtube_dl/extractor/youtube.py", line 1342, in _decrypt_signature
    video_id, player_url, s
  File "/opt/local/bin/youtube-dl/youtube_dl/extractor/youtube.py", line 1250, in _extract_signature_function
    res = self._parse_sig_js(code)
  File "/opt/local/bin/youtube-dl/youtube_dl/extractor/youtube.py", line 1314, in _parse_sig_js
    jscode, 'Initial JS player signature function name', group='sig')
  File "/opt/local/bin/youtube-dl/youtube_dl/extractor/common.py", line 1005, in _search_regex
    raise RegexNotFoundError('Unable to extract %s' % _name)
youtube_dl.utils.RegexNotFoundError: Unable to extract Initial JS player signature function name; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
 (caused by RegexNotFoundError('Unable to extract \x1b[0;34mInitial JS player signature function name\x1b[0m; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.')); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.

Change History (1)

comment:1 Changed 16 months ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Resolution: fixed
Status: newclosed

In eec4595407d62c6f1be3826cb804db33b45d3d77/macports-ports (master):

youtube-dl: Update to 2019.06.27

Closes: #58643

Note: See TracTickets for help on using tickets.