Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#58652 closed defect (duplicate)

Problem to update poppler

Reported by: lupin0lin Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: poppler

Description


Attachments (1)

main.log (443.7 KB) - added by lupin0lin 16 months ago.
Error message

Download all attachments as: .zip

Change History (7)

Changed 16 months ago by lupin0lin

Attachment: main.log added

Error message

comment:1 Changed 16 months ago by lupin0lin

To whom will concern it,

I met a problem to install(or upgrade) the poppler with Macports.
When I tried to run sudo port selfupdate outdated, it will be terminated when the Macport try to install poppler-0.77.
Here's the error message I obtained:

--->  Attempting to fetch poppler-0.77.0_0.darwin_16.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/poppler
--->  Fetching distfiles for poppler
--->  Attempting to fetch poppler-0.77.0.tar.xz from https://poppler.freedesktop.org/ 
--->  Verifying checksums for poppler
--->  Extracting poppler 
--->  Applying patches to poppler
--->  Configuring poppler
--->  Building poppler
Error: Failed to build poppler: command execution failed
Error: See /opt/local/var/macports
/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log for details.

I have attached the log file (main.log).
Can someone provide a way to solve the installation problem?

Last edited 16 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 16 months ago by kencu (Ken)

Resolution: duplicate
Status: newclosed

duplicate of 58574

comment:3 Changed 16 months ago by lupin0lin

Excuse me. In the ticket of 58574, I did not see a clear indication on how to fix my problem. Can someone clearly indicate it to me?

Thanks

comment:4 Changed 16 months ago by kencu (Ken)

My apologies for closing your ticket -- I'm not sure this issue has been fully fixed yet. But we should keep all the work in that other ticket so we have all the thinking in one place.

comment:5 Changed 16 months ago by kencu (Ken)

looks like if you uninstall poppler, then reinstall, it will work

comment:6 Changed 16 months ago by lupin0lin

Thanks. I uninstall poppler and reinstall it, and it works!

Note: See TracTickets for help on using tickets.