Opened 16 months ago

Closed 16 months ago

Last modified 15 months ago

#58658 closed defect (fixed)

xorg-libXxf86misc 1.0.4: Failed to configure xorg-libXxf86misc: No package 'xf86miscproto' found

Reported by: lhaeger (Lothar Haeger) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: chrstphrchvz (Christopher Chavez), yan12125 (Chih-Hsuan Yen), cjones051073 (Chris Jones)
Port: xorg-libXxf86misc xorg-xorgproto

Description

Here's what I get when trying to install xorg-libXxf86misc (as a dependency for xorg-server):

# sudo port install xorg-libXxf86misc
--->  Computing dependencies for xorg-libXxf86misc
--->  Configuring xorg-libXxf86misc
Error: Failed to configure xorg-libXxf86misc, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_x11_xorg-libXxf86misc/xorg-libXxf86misc/work/libXxf86misc-1.0.4/config.log
Error: Failed to configure xorg-libXxf86misc: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_x11_xorg-libXxf86misc/xorg-libXxf86misc/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port xorg-libXxf86misc failed

config.log tells me:

configure:18217: checking whether stripping libraries is possible
configure:18231: result: yes
configure:18257: checking if libtool supports shared libraries
configure:18259: result: yes
configure:18262: checking whether to build shared libraries
configure:18287: result: yes
configure:18290: checking whether to build static libraries
configure:18294: result: yes
configure:18335: checking for XXF86MISC
configure:18342: $PKG_CONFIG --exists --print-errors "xproto x11 xextproto xext xf86miscproto"
Package xf86miscproto was not found in the pkg-config search path.
Perhaps you should add the directory containing `xf86miscproto.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xf86miscproto' found
configure:18345: $? = 1
configure:18359: $PKG_CONFIG --exists --print-errors "xproto x11 xextproto xext xf86miscproto"
Package xf86miscproto was not found in the pkg-config search path.
Perhaps you should add the directory containing `xf86miscproto.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xf86miscproto' found
configure:18362: $? = 1
configure:18376: result: no
No package 'xf86miscproto' found
configure:18392: error: Package requirements (xproto x11 xextproto xext xf86miscproto) were not met:

No package 'xf86miscproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XXF86MISC_CFLAGS
and XXF86MISC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

xf86miscproto has been replaced by xorg-xorgproto recently:

sudo port install xorg-xf86miscproto                                                                                                                                                               1 ↵
--->  Configuring xorg-xf86miscproto
Error: xorg-xf86miscproto has been replaced by xorg-xorgproto; please install that instead.
Error: Failed to configure xorg-xf86miscproto: obsolete port
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_x11_xorg-xf86miscproto/xorg-xf86miscproto/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port xorg-xf86miscproto failed

It seems as if that change has not been promoted to all required places in the ports tree and/or build system yet. Manually installing xorg-xorgproto does NOT solve this issue.

Please find the build and log folders attached for analysis.

Attachments (1)

xorg-libXxf86misc_configure_error.tgz (390.8 KB) - added by lhaeger (Lothar Haeger) 16 months ago.

Download all attachments as: .zip

Change History (26)

Changed 16 months ago by lhaeger (Lothar Haeger)

comment:1 Changed 16 months ago by jmroot (Joshua Root)

Cc: jeremyhu added
Owner: set to cjones051073
Port: xorg-xorgproto added
Status: newassigned

comment:2 Changed 16 months ago by chrstphrchvz (Christopher Chavez)

I can reproduce this error when I try building from source, but somehow there is a binary available for 10.14.

comment:3 Changed 16 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:4 Changed 16 months ago by jmroot (Joshua Root)

Built against an older version of xorg-xorgproto perhaps?

comment:5 Changed 16 months ago by Chris Jones <jonesc@…>

Resolution: fixed
Status: assignedclosed

In 5c7a2b211087df88a0f6ae39d143143485374c17/macports-ports (master):

xorg-xorgproto: revert to 2018.4 release as 2019.1 breaks xorg-libXxf86misc
Closes:#58658

comment:6 Changed 16 months ago by lhaeger (Lothar Haeger)

Just to complete the process for those not too deep into macports: if xorg-xorgproto @2019.1 is already installed (it's a dependency many ports have after all):

  1. run "sudo port sync"
  2. run "port list xorg-xorgproto" and verify the latest version in the tree is now 2018.4 again
  3. run "sudo port uninstall xorg-xorgproto" (which ill uninstall @2019.1 and likely break some other ports)
  4. run "sudo port install xorg-xorgproto" to install 2018.4 and provide the dependencies removed with step 3

Now installing xorg-libXxf86misc should work as well as installing higher-level ports like xorg-server

comment:7 Changed 16 months ago by cjones051073 (Chris Jones)

Steps 3. and 4. above are not required. I bumped the epoch when reverting back to 2018.4 so it is considered an update, and hence a simple sudo port upgrade outdated will suffice.

comment:8 Changed 16 months ago by lhaeger (Lothar Haeger)

That's good to know, thanks for the fix, btw! I might have tried "port upgrade xorg-xorgproto" too early when the server side tree was not yet updated and nothing happened. An hour later the above did the trick for me then, sorry for any confusion caused by my posting too quickly.

comment:9 Changed 16 months ago by yan12125 (Chih-Hsuan Yen)

xf86miscproto is declared "LEGACY" in the latest version (1). An alternative to downgrading the port might be adding --enable-legacy to configure arguments.

(1) https://gitlab.freedesktop.org/xorg/proto/xorgproto/commit/96dd1aef70114dba33c6b3177d3b770941f8b4b1

comment:10 Changed 16 months ago by yan12125 (Chih-Hsuan Yen)

Cc: yan12125 added

comment:11 in reply to:  7 Changed 16 months ago by mf2k (Frank Schima)

Replying to cjones051073:

Steps 3. and 4. above are not required.

Neither is Step 2 because it does not tell you anything useful in this case. The output of port outdated or port outdated xorg-libXxf86misc is helpful however.

Last edited 16 months ago by mf2k (Frank Schima) (previous) (diff)

comment:12 Changed 16 months ago by lhaeger (Lothar Haeger)

So now we have the necessary steps documented for other "users" like me to find, goal achieved. :-)

Last edited 16 months ago by lhaeger (Lothar Haeger) (previous) (diff)

comment:13 Changed 16 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: closedreopened

comment:14 Changed 16 months ago by jmroot (Joshua Root)

Cc: cjones051073 added; jeremyhu removed
Owner: changed from cjones051073 to jeremyhu
Status: reopenedassigned

comment:15 Changed 16 months ago by cjones051073 (Chris Jones)

Yes....

Guess now is a good time to try out that --enable-legacy option...

comment:16 Changed 16 months ago by chrstphrchvz (Christopher Chavez)

Note that adding --enable-legacy to xorg-xorgproto introduces a conflict with xorg-printproto:

Error: Failed to activate xorg-xorgproto: Image error: /opt/local/include/X11/extensions/Print.h is being used by the active xorg-printproto port.
Last edited 16 months ago by chrstphrchvz (Christopher Chavez) (previous) (diff)

comment:17 Changed 16 months ago by cjones051073 (Chris Jones)

OK, so then that is not an easy quick fix option.

As I have already reverted this once, and as Jeremy updated it this time, I am going to leave it to him to decide how to fix this.

Last edited 16 months ago by cjones051073 (Chris Jones) (previous) (diff)

comment:18 in reply to:  16 Changed 16 months ago by chrstphrchvz (Christopher Chavez)

Replying to chrstphrchvz:

Note that adding --enable-legacy to xorg-xorgproto introduces a conflict with xorg-printproto:

xorg-fontcacheproto is another conflict I found. Not sure those are the only possible conflicts, but once those were both deactivated then xorg-libXxf86misc could configure and install.

comment:19 Changed 16 months ago by yan12125 (Chih-Hsuan Yen)

comment:20 Changed 16 months ago by cjones051073 (Chris Jones)

As far as xorg-libXxf86misc goes the number of ports depending on it is only two...

> git grep libXxf86misc
gnome/gnome-control-center/Portfile:                    port:xorg-libXxf86misc \
x11/xorg-libXxf86misc/Portfile:name            xorg-libXxf86misc
x11/xorg-libXxf86misc/Portfile:description     X.org libXxf86misc
x11/xorg-libXxf86misc/Portfile:distname        libXxf86misc-${version}
x11/xorg-libXxf86misc/Portfile:livecheck.regex libXxf86misc-(\\d+(?:\\.\\d+)*)
x11/xset/Portfile:                    port:xorg-libXxf86misc

So probably the best solution going forward is to look to removing these dependencies. Does xset or gnome-control-center really still need this ?

comment:21 Changed 16 months ago by cjones051073 (Chris Jones)

xset seems OK without the dep...

Last edited 16 months ago by cjones051073 (Chris Jones) (previous) (diff)

comment:22 Changed 16 months ago by cjones051073 (Chris Jones)

gnome port is also fine with the dep removed.

Will push an update committing this shortly. With this, nothing in the ports tree directly depends on xorg-libXxf86misc.

I cannot rule out other ports implicitly depending on it though, for instance I have already stumbled over xscreensaver that linked against it, even though it did not declare it as a dependency. rev-bumping should fix that.

Last edited 16 months ago by cjones051073 (Chris Jones) (previous) (diff)

comment:23 Changed 16 months ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: assignedclosed

In e7e08288ce814128ad51cc0cac71b887cf408083/macports-ports (master):

xorg-xorgproto: Install legacy protocols with xorg-xorgproto rather than legacy projects

Fixes #58658

Signed-off-by: Jeremy Huddleston Sequoia <jeremyhu@…>

comment:24 Changed 15 months ago by lhaeger (Lothar Haeger)

Could it be possible that this issue is still causing https://travis-ci.org/macports/macports-ports/builds/563422410 to fail with xcode 7 and 8?

comment:25 Changed 15 months ago by cjones051073 (Chris Jones)

I don't see how.

Note: See TracTickets for help on using tickets.