Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#58676 closed defect (fixed)

libuv fails to build on older systems

Reported by: devernay (Frédéric Devernay) Owned by: kencu (Ken)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: michaelld (Michael Dickens)
Port: libuv

Description

The following commit updated patch-libuv-unix-core-close-nocancel.diff to apply on 1.30.0, but older systems still build 1.29.1, and the patch fails to apply: https://github.com/macports/macports-ports/commit/d3ecce66e9ef3705abc4202a2224858311cee3a1#diff-f606ed54acfd3266d8b302066d568d8e

There should be two versions of this patch: one for 1.29.1 (older systems), and one for newer systems.

Change History (5)

comment:1 Changed 16 months ago by michaelld (Michael Dickens)

Agreed!

@kencu: are you available to do this? I won’t be able to for a bit (as you know).

comment:2 Changed 16 months ago by kencu (Ken)

I'll take a look.

comment:3 Changed 16 months ago by devernay (Frédéric Devernay)

@kencu I succesfully built libuv on 10.6 by simply putting the old version of the patch. So it's really just a matter of adding a copy of that old patch and referring to it for older systems.

comment:4 Changed 16 months ago by kencu (Ken)

Owner: set to kencu
Resolution: fixed
Status: newclosed

In 3524ec43e6678dea555acf9ef45548c51fbb7451/macports-ports (master):

libuv: bump older systems to 1.30.0

closes: #58676

comment:5 Changed 16 months ago by kencu (Ken)

I thought it might just be easier to move the older systems up to 1.30.0. It built on 10.4 - 10.6 for me without any troubles, and the test runs look pretty good, except on Tiger that does need some work to bring the test suite up to par.

Note: See TracTickets for help on using tickets.